Home | Tutorials | Wiki | Issues
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Finally, it works! So I ended up restarting the computer and then doing a fresh clone of the gazebo repo, but this time to my home directory. Everything else was the same and now everything works great!

Here are the set of commands that worked for me (the first three steps are only necessary if you don't already have Homebrew, XQuartz, and/or mercurial installed).

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
brew install caskroom/cask/xquartz
brew install mercurial
brew tap osrf/simulation
brew install gazebo9 --only-dependencies

hg clone https://bitbucket.org/osrf/gazebo ~/gazebo
mkdir -p ~/gazebo/build
cd ~/gazebo/build
hg up gazebo9
cmake -DCMAKE_BUILD_TYPE=Debug ../
sudo reboot

make -j4
source ~/gazebo/build/setup.sh
make install
gazebo --verbose

Finally, it works! So I ended up restarting the computer and then doing a fresh clone of the gazebo repo, but this time to my home directory. Everything else was the same and now everything works great!

Here are the set of commands that worked for me (the first three steps are only necessary if you don't already have Homebrew, XQuartz, and/or mercurial installed).

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
brew install caskroom/cask/xquartz
brew install mercurial
brew tap osrf/simulation
brew install gazebo9 --only-dependencies

hg clone https://bitbucket.org/osrf/gazebo ~/gazebo
mkdir -p ~/gazebo/build
cd ~/gazebo/build
hg up gazebo9

export PATH="/usr/local/opt/qt/lib/cmake/Qt5:$PATH"
cmake -DCMAKE_BUILD_TYPE=Debug ../
sudo reboot
 export LIBRARY_PATH=${LIBRARY_PATH}:/usr/local/opt/gettext/lib
make -j4
source ~/gazebo/build/setup.sh
make install
gazebo --verbose

Finally, it works! So I ended up restarting the computer and then doing a fresh clone of the gazebo repo, but this time to my home directory. Everything else was the same and now everything works great!

Here are the set of commands that worked for me (the first three steps are only necessary if you don't already have Homebrew, XQuartz, and/or mercurial installed).

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
brew install caskroom/cask/xquartz
brew install mercurial
brew tap osrf/simulation
brew install gazebo9 --only-dependencies

hg clone https://bitbucket.org/osrf/gazebo ~/gazebo
mkdir -p ~/gazebo/build
cd ~/gazebo/build
hg up gazebo9

export PATH="/usr/local/opt/qt/lib/cmake/Qt5:$PATH"
cmake -DCMAKE_BUILD_TYPE=Debug ../

export LIBRARY_PATH=${LIBRARY_PATH}:/usr/local/opt/gettext/lib
make -j4
sudo make install

(might need to reboot before running Gazebo for the first time works)

source ~/gazebo/build/setup.sh
make install
gazebo --verbose

Finally, it works! So I ended up restarting the computer and then doing a fresh clone of the gazebo repo, but this time to my home directory. Everything else was the same and now everything works great!

Here are the set of commands that worked for me (the first three steps are only necessary if you don't already have Homebrew, XQuartz, and/or mercurial installed).

/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
brew install caskroom/cask/xquartz
brew install mercurial
brew tap osrf/simulation
brew install gazebo9 --only-dependencies

hg clone https://bitbucket.org/osrf/gazebo ~/gazebo
mkdir -p ~/gazebo/build
cd ~/gazebo/build
hg up gazebo9

export PATH="/usr/local/opt/qt/lib/cmake/Qt5:$PATH"
cmake -DCMAKE_BUILD_TYPE=Debug ../

export LIBRARY_PATH=${LIBRARY_PATH}:/usr/local/opt/gettext/lib
make -j4
sudo make install

(might need to reboot computer before running Gazebo for the first time works)time)

source ~/gazebo/build/setup.sh
gazebo --verbose