Home | Tutorials | Wiki | Issues
Ask Your Question

Revision history [back]

Hi

You did not load the model correctly, try it like this in your .world file:

<world>
...
    <include>
        <uri>model://my_model</uri>
        <pose>0.3 0.5 0.9 0 0 0</pose>
    </include>
</world>

If it doesn't work, make sure that you have your GAZEBO PATHS set correctly. Or just add the .model file to ~/.gazebo/models folder.

If you still have trouble ask for more info.

Cheers, Andrei

Hi

You did not load the model correctly, try it like this in your .world file:

<world>
...
    <include>
        <uri>model://my_model</uri>
        <pose>0.3 0.5 0.9 0 0 0</pose>
    </include>
</world>

If it doesn't work, make sure that you have your GAZEBO PATHS set correctly. Or just add the .model file to ~/.gazebo/models folder.

If you still have trouble ask for more info.

UPDATE!!! an example of setting the paths (plugin, model, resource):

export GAZEBO_PLUGIN_PATH=~/<path>/my_package_example/lib:${GAZEBO_PLUGIN_PATH}

export GAZEBO_MODEL_PATH=~/<path>/my_package_example/models:${GAZEBO_MODEL_PATH}

export GAZEBO_RESOURCE_PATH=~/<path>/my_package_example/models:${GAZEBO_RESOURCE_PATH}

Cheers, Andrei