Home | Tutorials | Wiki | Issues
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Another thing to consider is your joint damping. Some of the values in your example (test2) have a joint damping of 0.5. Unfortunately, with the default settings, ODE becomes unstable for large damping values like that. The easiest thing to do is to add the following snippet in each of your joints:

<physics>
    <ode>
        <implicit_spring_damper>1</implicit_spring_damper>
    </ode>
</physics>

Here's an answer that also shows how to do it in URDF: http://answers.gazebosim.org/question/8317/setting-high-damping-breaks-model/

Alternatively, you can look into using DART as the physics engine. In my testing, it was able to run your example without any modifications.