Home | Tutorials | Wiki | Issues
Ask Your Question
0

After updating to Gazebo 1.3 under ROS Groovy I get a .launch file error

asked 2013-01-30 05:27:49 -0600

AndreiHaidu gravatar image

Hi,

Another question that might be related to this one.

I am using ROS Groovy and I updated Gazebo to 1.3 (binary version), under Ubuntu 12.04. When launching an empty world with the following .launch file:

<launch>

  <arg name="use_sim_time" default="true"/>
  <arg name="gui" default="true"/>

  <!-- set use_sim_time flag -->
  <group if="$(arg use_sim_time)">
    <param name="/use_sim_time" value="true" />
  </group>


  <!-- start empty world -->
  <node name="empty_world_server" pkg="gazebo" type="gazebo" args="$(find hit_hand)/worlds/empty.world" respawn="false" output="screen"/>

  <!-- start gui -->
  <group if="$(arg gui)">
    <node name="gazebo_gui" pkg="gazebo" type="gui" respawn="false" output="screen"/>
  </group>

</launch>

I get the following error:

Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://groovybeetz4:44318/

SUMMARY
========

PARAMETERS
 * /rosdistro
 * /rosversion
 * /use_sim_time

NODES
  /
    empty_world_server (gazebo/gazebo)
    gazebo_gui (gazebo/gui)

auto-starting new master
process[master]: started with pid [6184]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 8a994a92-6ace-11e2-b2ca-6cf049e83b7a
process[rosout-1]: started with pid [6197]
started core service [/rosout]
process[empty_world_server-2]: started with pid [6211]
process[gazebo_gui-3]: started with pid [6220]
GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2.1) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /opt/ros/groovy/stacks/simulator_gazebo/gazebo/gazebo/bin/gzserver...(no debugging symbols found)...done.
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
Gazebo multi-robot simulator, version 1.3.0
Copyright (C) 2012 Nate Koenig, John Hsu, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[New Thread 0x7fffe5e77700 (LWP 6248)]
Gazebo multi-robot simulator, version 1.3.0
Copyright (C) 2012 Nate Koenig, John Hsu, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2013-02-05 04:54:55 -0600

AndreiHaidu gravatar image

I figured it out, in the launch file the node name is not allowed anymore to have the "_" character in the name.

<!-- start empty world -->
  <node name="empty_world_server" .. />

becomes:

<!-- start empty world -->
  <node name="emptyworldserver" .. />
edit flag offensive delete link more

Comments

I'm almost positive that's not true.

Neil Traft gravatar imageNeil Traft ( 2014-07-09 20:00:16 -0600 )edit

this must have been a bug at the moment: `terminate called after throwing an instance of 'ros::InvalidNameException' what(): Character [-] at element [20] is not valid in Graph Resource Name [empty_world_server13-01-30]. Valid characters are a-z, A-Z, 0-9, / and _.` event though the `_` is listed.

AndreiHaidu gravatar imageAndreiHaidu ( 2014-07-10 03:48:49 -0600 )edit

Yeah that's referring to a graphics resource name, not a node name. But I think I've recently discovered the source of that error: it's a bug in Gazebo 1.5 on 32-bit machines.

Neil Traft gravatar imageNeil Traft ( 2014-07-24 17:31:46 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2013-01-30 05:27:49 -0600

Seen: 1,674 times

Last updated: Feb 05 '13