Home | Tutorials | Wiki | Issues
Ask Your Question
0

URDF from a working ROS package not shown

asked 2015-11-18 03:19:09 -0500

yah130s gravatar image

updated 2015-11-20 05:38:39 -0500

I'm creating a Gazebo package for a URDF-based, dual-arm robot. Its ROS package has been working for years. Robot model doesn't appear on Gazebo, wireframe or collision either. What should I check?

URDF (it's URDF but in the launch file I use this as a xacro). The entire Gazebo package can be seen in this pull request.

Saw a similar thread but most of the joints in my model aren't fixed.

Also, this 'invisible' robot keeps falling (so I'm trying to add contact parameters), but this is another problem.

Gazebo 2.2.6, ROS Indigo Thank you.


Update) Adding environment variables trick to package.xml` in the package that contains models didn't work unfortunately.

Meanwhile, I don't see either the list of links in the model pane. I only see __default__, string of which doesn't exist anywhere in my packages. image description

edit retag flag offensive close merge delete

Comments

1

This looks similar to the problems I encountered here: http://answers.gazebosim.org/question/7178/mesh-geometries-using-xacro-not-working-with-drcsimgazebo4-working-previously-with-drcsimgazebo2/ and here: https://bitbucket.org/ihmcrobotics/ihmc_ros/issues/52/atlas-controller-fails-to-work-properly. You could test if it's the same resource loading issue by adding primitive based geometry. That worked in my cases (but didn't help with the meshes obviously).

Stefan Kohlbrecher gravatar imageStefan Kohlbrecher ( 2015-11-23 09:27:42 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-01-07 06:22:39 -0500

yah130s gravatar image

updated 2016-01-07 21:22:24 -0500

I figured it out. As noted in "Inertial Element" section in the URDF in Gazebo tutorial (sorry linking didn't work, maybe with brackets in the URL?), mass must be greater than zero for any link to not be ignored. In my case there were a few link in the upstream nodes whose mass was 0.

Good standalone debugging tool gzsdf (for Gazebo2) was also mentioned in this chapter.

edit flag offensive delete link more
2

answered 2015-11-19 02:22:45 -0500

updated 2015-11-19 04:21:49 -0500

Addition:

you might need something like this in your package xml to ensure that gazebo finds model path

<export>
     <gazebo_ros plugin_path="${prefix}/lib"
            gazebo_media_path="${prefix}/.."      
            gazebo_resource_path="${prefix}/..:${prefix}/resource"
            gazebo_model_path="${prefix}/.."/>
</export>

I once had some problems with missing intertias for link that caused some problems. One last thing that might be missing are transmissions.

I don't have the time to look at the complete URDF so all of this are just guesses

Old answer:

Your launch file has -sdf instead of -urdf in the arguments. Please let me know if this does not solve your problem...

edit flag offensive delete link more

Comments

Thanks for taking a look. No changing to `-urdf` didn't work (although it sounds the right thing to do. I've updated the link in my OP).

yah130s gravatar imageyah130s ( 2015-11-19 03:42:59 -0500 )edit

updated the answer, I am not sure if you have been notified...

evilBiber gravatar imageevilBiber ( 2015-11-20 02:02:50 -0500 )edit

@evilBiber thx again, for some reason email notification stopped for me. Anyways I've updated my OP.

yah130s gravatar imageyah130s ( 2015-11-20 05:45:51 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-11-18 03:19:09 -0500

Seen: 2,141 times

Last updated: Jan 07 '16