Home | Tutorials | Wiki | Issues
Ask Your Question
0

Ground/floor plane not visible

asked 2013-02-06 08:08:48 -0600

bcoenen gravatar image

Hi, the ground plane in this world file appears to be not visible:

<rendering:ogre>
   <ambient>0.5 0.5 0.5 0.5</ambient>
   <sky>
      <material>Gazebo/CloudySky</material>
   </sky>
   <grid>false</grid>
   <maxUpdateRate>10.</maxUpdateRate>
   <shadowTechnique>none</shadowTechnique>
   <shadows>false</shadows>
</rendering:ogre>

<!-- ground plane -->
   <model:physical name="gplane">
      <xyz>0 0 0</xyz>    
      <rpy>0 0 0</rpy>
      <static>true</static>

      <body:plane name="plane">
         <geom:plane name="plane">
            <laserRetro>2000.0</laserRetro>
            <mu1>50.0</mu1>
            <mu2>50.0</mu2>
            <kp>1000000000.0</kp>
            <kd>1.0</kd>
            <normal>0 0 1</normal>
            <size>100 100</size>
            <segments>10 10</segments>
            <uvTile>100 100</uvTile>
            <material>Gazebo/GrayGrid</material>
         </geom:plane>
      </body:plane>
   </model:physical>

Might this be because it is transparant? How can this be resolved?

Thanks

edit retag flag offensive close merge delete

Comments

I'm using version 1.0.2. How do I set the material correct? Is GreyGrid the correct material name? Because if I change it from Gray to Grey the problem is still present...

bcoenen gravatar imagebcoenen ( 2013-02-07 04:21:56 -0600 )edit

Is that version 1.0.2 as reported by ROS? The string "Gazebo/GrayGrid" refers to a material script in a file called gazebo.material (or Gazebo.material depending on your version). This file should exist in your GAZEBO_RESOURCE_PATH. You can also check ~/.gazebo/orgre.log for errors.

nkoenig gravatar imagenkoenig ( 2013-02-07 09:21:16 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-02-08 03:40:04 -0600

bcoenen gravatar image

Indeed GrayGrid or GreyGrid was not present in the Gazebo.material file. I finally solved by setting it to Grey and by defining the material as visual:

    <visual>
      <material>Gazebo/Grey</material>
    </visual>
edit flag offensive delete link more
1

answered 2013-02-06 08:17:16 -0600

nkoenig gravatar image

It looks like your using a world file that dates from pre-gazebo 1.0. Are you also using a version of gazebo from that era?

If so, I would make sure the GreyGrid material is correct.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-02-06 08:08:48 -0600

Seen: 1,842 times

Last updated: Feb 08 '13