Home | Tutorials | Wiki | Issues
Ask Your Question
0

Gazebo Installation on Windows 7 32 bit

asked 2016-01-31 22:59:29 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

in the tutorial it states that :

In a Windows shell, configure and build Ignition Math

cd ign-math mkdir build
cd build ..\configure nmake nmake install

If I input it on windows cmd this happens:

Microsoft Windows [Version 6.1.7601] Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\home>cd ign-math

C:\Users\home\ign-math>mkdir build A subdirectory or file build already exists.

C:\Users\home\ign-math>cd build

C:\Users\home\ign-math\build>..\configure Configuring for build type Debug

C:\Users\home\ign-math\build>cmake -G "NMake Makefiles" -DCMAKE_INSTALL_PREFIX=" install\Debug" -DCMAKE_BUILD_TYPE="Debug" -DENABLE_TESTS_COMPILATION:BOOL=False .. -- The C compiler identification is unknown -- The CXX compiler identification is unknown CMake Error at CMakeLists.txt:9 (project): The CMAKE_C_COMPILER:

cl

is not a full path and was not found in the PATH.

To use the NMake generator with Visual C++, cmake must be run from a shell that can use the compiler cl from the command line. This environment is unable to invoke the cl compiler. To fix this problem, run cmake from the Visual Studio Command Prompt (vcvarsall.bat).

Tell CMake where to find the compiler by setting either the environment variable "CC" or the CMake cache entry CMAKE_C_COMPILER to the full path to the compiler, or to the compiler name if it is in the PATH.

CMake Error at CMakeLists.txt:9 (project): The CMAKE_CXX_COMPILER:

cl

is not a full path and was not found in the PATH.

To use the NMake generator with Visual C++, cmake must be run from a shell that can use the compiler cl from the command line. This environment is unable to invoke the cl compiler. To fix this problem, run cmake from the Visual Studio Command Prompt (vcvarsall.bat).

Tell CMake where to find the compiler by setting either the environment variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path to the compiler, or to the compiler name if it is in the PATH.

-- Configuring incomplete, errors occurred! See also "C:/Users/home/ign-math/build/CMakeFiles/CMakeOutput.log". See also "C:/Users/home/ign-math/build/CMakeFiles/CMakeError.log".

C:\Users\home\ign-math\build>nmake 'nmake' is not recognized as an internal or external command, operable program or batch file.

C:\Users\home\ign-math\build>nmake install 'nmake' is not recognized as an internal or external command, operable program or batch file.

C:\Users\home\ign-math\build> C:\Users\home\ign-math\build> C:\Users\home\ign-math\build>

If I input it on it on Git cmd the same thing happens.

What should I do?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-11-27 00:03:27 -0600

Vaidehi gravatar image
edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-01-31 22:59:29 -0600

Seen: 504 times

Last updated: Nov 27 '16