Home | Tutorials | Wiki | Issues
Ask Your Question
0

gazebo installation on windows 7 32 bit

asked 2016-02-16 22:05:35 -0600

van4lyf gravatar image

im asked in the tutorial to input this:

cd ign-math mkdir build cd build ..\configure nmake nmake install

and this spews out :

Microsoft Windows [Version 6.1.7601] Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\home>cd ign-math

C:\Users\home\ign-math>mkdir build A subdirectory or file build already exists.

C:\Users\home\ign-math>cd build

C:\Users\home\ign-math\build>..\configure Configuring for build type Debug

C:\Users\home\ign-math\build>cmake -G "NMake Makefiles" -DCMAKE_INSTALL_PREFIX=" install\Debug" -DCMAKE_BUILD_TYPE="Debug" -DENABLE_TESTS_COMPILATION:BOOL=False .. -- The C compiler identification is unknown -- The CXX compiler identification is unknown CMake Error at CMakeLists.txt:9 (project): The CMAKE_C_COMPILER:

cl is not a full path and was not found in the PATH.

To use the NMake generator with Visual C++, cmake must be run from a shell that can use the compiler cl from the command line. This environment is unable to invoke the cl compiler. To fix this problem, run cmake from the Visual Studio Command Prompt (vcvarsall.bat).

Tell CMake where to find the compiler by setting either the environment variable "CC" or the CMake cache entry CMAKE_C_COMPILER to the full path to the compiler, or to the compiler name if it is in the PATH.

CMake Error at CMakeLists.txt:9 (project): The CMAKE_CXX_COMPILER:

cl is not a full path and was not found in the PATH.

To use the NMake generator with Visual C++, cmake must be run from a shell that can use the compiler cl from the command line. This environment is unable to invoke the cl compiler. To fix this problem, run cmake from the Visual Studio Command Prompt (vcvarsall.bat).

Tell CMake where to find the compiler by setting either the environment variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path to the compiler, or to the compiler name if it is in the PATH.

-- Configuring incomplete, errors occurred! See also "C:/Users/home/ign-math/build/CMakeFiles/CMakeOutput.log". See also "C:/Users/home/ign-math/build/CMakeFiles/CMakeError.log".

C:\Users\home\ign-math\build>nmake 'nmake' is not recognized as an internal or external command, operable program or batch file.

C:\Users\home\ign-math\build>nmake install 'nmake' is not recognized as an internal or external command, operable program or batch file.

C:\Users\home\ign-math\build>

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-02-17 07:43:46 -0600

snakeplisk gravatar image

Make sure you follow all steps here: http://gazebosim.org/tutorials?tut=in...

Note: 8. Open a regular Windows shell (Start->Run->"cmd"->enter), and load your compiler setup by copying and pasting the following line:

"C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\vcvarsall.bat" x86_amd64

This will fix your problem.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-02-16 22:05:35 -0600

Seen: 490 times

Last updated: Feb 17 '16