Home | Tutorials | Wiki | Issues
Ask Your Question
0

Colours in Gazebo 5 are always shown white

asked 2016-02-25 07:24:12 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi everybody,

It's the simplest problem I've faced, but I'm not able to solve it. I'm working with an urdf file with Gazebo 5. The problem is that in Gazebo the colours doesn't appear as I want, they always appear white:

image description

However, adding a model from the gazebo database works right and the colors are shown properly. I think the problem is in the urdf file, but I don't know where the mistake is. When I was working with Gazebo 2 the colors from worked propely but when I moved to Gazebo 5 they don't work.

Thanks!!

edit retag flag offensive close merge delete

Comments

I have this problem too. To have colour on my link, I use dae meshes which contain the texture.

Brosseau.F gravatar imageBrosseau.F ( 2016-02-26 01:38:36 -0600 )edit

I have the same problem. But it looks like *not* all of the colors from the standard models are shown as well. Have you managed to solve this problem?

ZhekaS gravatar imageZhekaS ( 2016-05-28 22:49:02 -0600 )edit

Having the same issue. I filed a bug report because it seems like no one has solved it... https://bitbucket.org/osrf/sdformat/issues/132/parser-does-not-handle-urdf-material

plusk01 gravatar imageplusk01 ( 2017-01-05 00:32:06 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-05-30 08:24:10 -0600

ZhekaS gravatar image

Gazebo is using it's own materials to display the appearance of the links. You need to add a gazebo-specific material tag to each one of your links:

<gazebo reference="imu_link">
    <material>Gazebo/Red</material>
</gazebo>

Here in reference gives the name of your link. You can find the available materials in your gazebo installation: gazebo/media/materials/scripts/gazebo.material IMPORTANT: I've found out that the material tag should go exactly like this, without any extra spaces around the Gazebo/Red string. Otherwise it is just silently ignored and your link is appearing white..

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2016-02-25 07:24:12 -0600

Seen: 909 times

Last updated: May 30 '16