Home | Tutorials | Wiki | Issues
Ask Your Question
0

How to update Gazebo-2.2 to Gazebo-7?

asked 2016-03-14 12:06:41 -0500

baila gravatar image

Hi all, i have installed ROS Indigo on my Ubuntu 14.04 LTS-64 bit machine. It includes Gazebo-2.2 with it. I want to update the Gazebo-7.

I want to know - 1. How can i update it to Gazebo-7? 2. If i do update, will there be any issue with my current ROS installation or functionality?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-03-14 12:08:26 -0500

nkoenig gravatar image

Yes, you can install gazebo-7 with Indigo.

Here is more information: http://gazebosim.org/tutorials?tut=ro...

edit flag offensive delete link more

Comments

I have used "sudo apt-get install gazebo7". But it is giving me errors like:
The following packages have unmet dependencies: gazebo7 : Depends: libgazebo7 (= 7.0.0-1~trusty) but it is not going to be installed Depends: gazebo7-common (= 7.0.0-1~trusty) but it is not going to be installed Recommends: gazebo7-plugin-base E: Unable to correct problems, you have held broken packages.
But "apt-mark showhold" is not showing anything.

baila gravatar imagebaila ( 2016-03-14 13:21:08 -0500 )edit

Thanks for your help nkoenig. I have updated my gazebo-2.2 by "sudo apt-get install ros-indigo-gazebo7-ros-pkgs". Hope it will work fine. Thanks.

baila gravatar imagebaila ( 2016-03-14 13:31:17 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-03-14 12:06:41 -0500

Seen: 1,056 times

Last updated: Mar 14 '16