Home | Tutorials | Wiki | Issues
Ask Your Question
0

installing gazebo from dev branch

asked 2012-09-25 06:28:21 -0600

logicalguy gravatar image

Today I tried to install gazebo from the dev branch, and it fails at the compile stage because it can't find urdf related files. So do I now have to install the ROS system to get Gazebo working? How do I proceed?

Thanks.

edit retag flag offensive close merge delete

6 Answers

Sort by » oldest newest most voted
0

answered 2012-09-28 13:09:49 -0600

nkoenig gravatar image

This problem has been fixed in the dev branch. Update and you will be fine.

edit flag offensive delete link more
0

answered 2012-10-05 05:43:24 -0600

logicalguy gravatar image

Thanks, nkoenig, it is indeed fixed, but when I pulled in the latest changes today and tried to compile, this is what I get:

Linking CXX shared library libgazebo_msgs.so
[ 39%] Built target gazebo_msgs
Scanning dependencies of target gazebo_physics_bullet
[ 40%] Building CXX object gazebo/physics/bullet/CMakeFiles/gazebo_physics_bullet.dir/BulletPhysics.cc.o
/home/ro/playerstagegazebo/gazebo-dev/gazebo/physics/bullet/BulletPhysics.cc: In function ‘gazebo::physics::PhysicsEnginePtr NewBulletPhysics(gazebo::physics::WorldPtr)’:
/home/ro/playerstagegazebo/gazebo-dev/gazebo/physics/bullet/BulletPhysics.cc:60:1: error: cannot allocate an object of abstract type ‘gazebo::physics::BulletPhysics’
/home/ro/playerstagegazebo/gazebo-dev/gazebo/physics/bullet/BulletPhysics.hh:48:5: note:   because the following virtual functions are pure within ‘gazebo::physics::BulletPhysics’:
/home/ro/playerstagegazebo/gazebo-dev/gazebo/physics/PhysicsEngine.hh:104:32: note:     virtual gazebo::physics::JointPtr gazebo::physics::PhysicsEngine::CreateJoint(const std::string&, gazebo::physics::ModelPtr)
/home/ro/playerstagegazebo/gazebo-dev/gazebo/physics/bullet/BulletPhysics.cc: At global scope:
/home/ro/playerstagegazebo/gazebo-dev/gazebo/physics/bullet/BulletPhysics.cc:67:11: error: ‘btCollisionObjectWrapper’ does not name a type
/home/ro/playerstagegazebo/gazebo-dev/gazebo/physics/bullet/BulletPhysics.cc:67:36: error: ISO C++ forbids declaration of ‘parameter’ with no type
/home/ro/playerstagegazebo/gazebo-dev/gazebo/physics/bullet/BulletPhysics.cc:68:28: error: ‘btCollisionObjectWrapper’ does not name a type
/home/ro/playerstagegazebo/gazebo-dev/gazebo/physics/bullet/BulletPhysics.cc:68:53: error: ISO C++ forbids declaration of ‘parameter’ with no type
/home/ro/playerstagegazebo/gazebo-dev/gazebo/physics/bullet/BulletPhysics.cc: In constructor ‘gazebo::physics::BulletPhysics::BulletPhysics(gazebo::physics::WorldPtr)’:
/home/ro/playerstagegazebo/gazebo-dev/gazebo/physics/bullet/BulletPhysics.cc:99:27: error: invalid conversion from ‘bool (*)(btManifoldPoint&, const int*, int, int, const int*, int, int)’ to ‘bool (*)(btManifoldPoint&, const btCollisionObject*, int, int, const btCollisionObject*, int, int)’
/home/ro/playerstagegazebo/gazebo-dev/gazebo/physics/bullet/BulletPhysics.cc: In function ‘gazebo::physics::PhysicsEnginePtr NewBulletPhysics(gazebo::physics::WorldPtr)’:
/home/ro/playerstagegazebo/gazebo-dev/gazebo/physics/bullet/BulletPhysics.cc:60:1: warning: control reaches end of non-void function
make[2]: *** [gazebo/physics/bullet/CMakeFiles/gazebo_physics_bullet.dir/BulletPhysics.cc.o] Error 1
make[1]: *** [gazebo/physics/bullet/CMakeFiles/gazebo_physics_bullet.dir/all] Error 2
make: *** [all] Error 2
edit flag offensive delete link more

Comments

Well, this problem went away when I upgraded to the latest version of bullet - ver 2.81. It wasn't yet in the gentoo repositories/overlays, so I had to compile from source.

logicalguy gravatar imagelogicalguy ( 2012-10-16 05:29:58 -0600 )edit
0

answered 2012-10-05 05:50:05 -0600

logicalguy gravatar image

ThomasK, which OS are you using?

I'm using Gentoo on x86-64 and I have OGRE with the nvidia plugin installed via the Gentoo Portage package management system.

edit flag offensive delete link more
0

answered 2012-09-26 12:38:06 -0600

ThomasK gravatar image

I'm somehow unable to comment on any of your posts, just on mine, so I'll have to write another answer ...

Heightmaps are actually the only thing that throw an error for me, so you might not be happy with it unless you figure out how to fix it. ;) It tries to use OGRE's Plugin_CgProgramManager.so library which doesn't exist in my OGRE installation. Maybe it's just missing in the debian package installation and you'll get it by manually compiling OGRE.

Error [RenderEngine.cc:388] Unable to load Ogre Plugin[/usr/lib/x8664-linux-gnu/OGRE-1.7.4/PluginCgProgramManager.so]Heightmaps(Terrain) will not display properly.

edit flag offensive delete link more
0

answered 2012-09-26 04:08:47 -0600

logicalguy gravatar image

Well, I'm interested in importing height maps as terrain and driving around a pioneer 2AT robot in it. The pioneer 2AT has recently been made available in the dev branch, plus some other work on the heightmaps terrain - hence!!

edit flag offensive delete link more
0

answered 2012-09-25 22:14:34 -0600

ThomasK gravatar image

What feature do you need that's only in the dev branch? The fancy sky? ;) I just tried compiling the dev branch on my laptop which apparently had the same package missing as you I guess. I installed ros-fuerte-urdfdom which installed the missing headers. This package depends on ros-fuerte-console-bridge which in turn doesn't depend on any ros packages though so it should be possible to install ros-fuerte-urdfdom without installing ROS. There is also a package called ros-fuerte-urdfdom-headers which only depends on boost but installing just this package did not install the required headers (which is kinda odd given that the package's description is "Header files for core data structures used by URDF parsers").

Btw I'd recommend using John's branch over dev, it's usually more active than dev. ... Actually I'd recommend using none of them and wait for a new official version which should hopefully be released end of next month (at least that's what I'm hoping for ...).

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2012-09-25 06:28:21 -0600

Seen: 667 times

Last updated: Oct 05 '12