Laser incorrect simulation, not REP117 compliant

asked 2016-06-23 05:25:14 -0600

updated 2016-07-20 04:17:15 -0600

Hi,

I am writing here instead of reporting a Gazebo issue because I am not sure if I am doing something wrong.

REP117 states that: "Detections that are too close to the sensor to quantify shall be represented by -Inf. Erroneous detections shall be represented by quiet (non-signaling) NaNs. Finally, out of range detections will be represented by +Inf." And this PR implemented it. I do not know which release is that, but Gazebo 5.3.0, the one I am using, has this fix.

However, if I simply insert a Hokuyo laser and place and object too close, we see that the measurements below minimum range are incorrect (they go within the obstacle) and ranges with max_range are reported as max_range:

image description

Furthermore, using the gazebo_ros plugin libgazebo_ros_laser.so I can see that it is reported exactly the same as in the topic visualization (wrong min_range instead of -inf and max_range instead of inf).

Is this a bug or I am doing something wrong?

EDIT: I have tested this in Gazebo7, and max range is converted to +inf correctly, but minimum range keeps doing the same (more or less).

Thanks a lot!

edit retag flag offensive close merge delete

Comments

@nkoenig could you please check this?

Javi V gravatar imageJavi V ( 2016-07-01 02:31:26 -0600 )edit