Home | Tutorials | Wiki | Issues
Ask Your Question
0

No plugins interface shown in the model tree

asked 2016-07-21 08:37:18 -0600

NelsonB gravatar image

Hello, I'm quite new to Gazebo, and I'm currently trying to use it with px4 Sim works fine, but I tried to create my own model following the gazebo tutorial, and am stuck when it deals with inserting a plug'in, because I have no model plugin in the tree. I tried with gazebo6 then gazebo7, result is the same. When using models with plugins linked to the px4 simulator, the models react correctly to my inputs, so I guess plugins are currently working, but I have no interface to add /configure them. I set all the system variables with the usr/share/gazebo/setup.sh script, didn't change a thing.

Anyone has a clue about that? Nelson.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-07-21 11:42:51 -0600

Unfortunately, up to Gazebo7, no plugin information is displayed on the Model Tree, so there's no easy way to check from the GUI whether your plugin was loaded or not.

Luckily, this is something we're actively working on, and plugins will be listed on the model tree from Gazebo8 :)

edit flag offensive delete link more
0

answered 2016-07-21 09:13:48 -0600

NelsonB gravatar image

Sorry for the post, I just re checked, my last try using the /usr/share/gazebo/setup.sh script seems to solve my problem.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-07-21 08:37:18 -0600

Seen: 138 times

Last updated: Jul 21 '16