Home | Tutorials | Wiki | Issues
Ask Your Question
0

Robots change shape and are fixed/stuck.

asked 2016-08-13 08:38:20 -0500

RHolland gravatar image

Hey, I've been using 25 robots of the same type in a swarm simulation in Gazebo 2.2.3 on ROS Indigo. After about an hour of simulation at least half the robots are fixed in the centre of the world and I cannot move them with the hand tool. They do not respond to their subscribed topics, and actually change shape. Using the service: '/gazebo/reset_world' does not reset these stuck robots. In the attached picture ( http://imgur.com/a/YKoYN ) are some of the normal robots and in the bottom right are about 10 fixed/stuck in the same place. I can't find anything like this online and there are no errors printed on console.


The robots themselves use the differential_drive_controllerplugin and are essentially the robots described in this tutorial: http://gazebosim.org/tutorials?tut=bu.... I have no idea how to address this and would much appreciate any ideas.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-08-14 11:21:17 -0500

RHolland gravatar image

I've fixed it, turns out I was sending NaN to the cmd_vel topic of the robot, crashing the diff_drive_controller. Still not sure why this disabled the robots as in the picture.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2016-08-13 08:38:20 -0500

Seen: 75 times

Last updated: Aug 14 '16