Home | Tutorials | Wiki | Issues
Ask Your Question
0

Gzweb not load well my world

asked 2016-09-09 06:07:38 -0500

aitormf gravatar image

updated 2016-09-12 03:36:15 -0500

I have create the following world C:\fakepath\road_drone_textures.world.

with gzclient Works perfectly but in Gzweb, when load the second lamp shows the following error:

image description

I has tried to solved it and I have edited gz3d.js adding a "if" to comprobate that link[0] exists (line 1613).

if (link[0])
        {        
        if (link[0].self_collide)
            {
                link[0].self_collide = this.trueOrFalse(stats.link[0].self_collide);
            }
            if (link[0].gravity)
            {
               link[0].gravity = this.trueOrFalse(stats.link[0].gravity);
            }
            if (link[0].kinematic)
            {
              link[0].kinematic = this.trueOrFalse(stats.link[0].kinematic);
            }
        }
      }

This is part of the function: GZ3D.Gui.prototype.setModelStats = function(stats, action) I don't know how this will affect to gzweb consistency but solved part of my problem: image description

the problem now is that gzweb not shows the road. Any idea's as solve it?

Thaks, Aitor (JdeRobot Team)

edit retag flag offensive close merge delete

Comments

Nice catch adding the `if` statement, it would be great if you could make a pull request to GzWeb with the fix.

chapulina gravatar imagechapulina ( 2016-09-09 11:19:54 -0500 )edit

+1 on making a pull request for this. Let us know if you want us to do it

iche033 gravatar imageiche033 ( 2016-09-09 18:22:07 -0500 )edit

I have make a fork of the Project and a new branch to solved this bug but, I don`t see how do the pull request

aitormf gravatar imageaitormf ( 2016-09-11 04:37:28 -0500 )edit

From this page, you should be able to choose your branch with the fix and make a pull request. Thanks! https://bitbucket.org/osrf/gzweb/pull-requests/new

chapulina gravatar imagechapulina ( 2016-09-12 11:03:28 -0500 )edit

I don't have access to create new pull request. My User in bitbucket is aitormf

aitormf gravatar imageaitormf ( 2016-09-13 04:56:29 -0500 )edit

Oh sory for the trouble. I hink it works if you go to your repo page and click on create pull request?

chapulina gravatar imagechapulina ( 2016-09-13 10:39:27 -0500 )edit

Oh sory for the trouble. I think it works if you go to your repo page and click on create pull request?

chapulina gravatar imagechapulina ( 2016-09-13 10:39:45 -0500 )edit

Sorry for my late reply chapulina, I have done the pull request (#93)

aitormf gravatar imageaitormf ( 2016-09-21 02:42:26 -0500 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2016-09-09 18:18:50 -0500

iche033 gravatar image

Here's a pull request to fix rendering roads.

edit flag offensive delete link more

Comments

It works perfect, with this pull request gzweb shows all world, thaks, Aitor (JdeRobot Team)

aitormf gravatar imageaitormf ( 2016-09-12 03:34:17 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-09-09 06:07:38 -0500

Seen: 206 times

Last updated: Sep 12 '16