Home | Tutorials | Wiki | Issues
Ask Your Question
0

Gazebo 2 runs at 0.5 simulation speed

asked 2016-09-19 20:10:50 -0600

jerryandt gravatar image

updated 2016-09-20 00:13:01 -0600

I am loading 2 models into gazebo-2 and find that the ratio of real-time is never better than 0.5 and is typically 0.2. currently using => Geforce GTX 750Ti 2-slot PCI-e 4GB. My processor is an Intel-i7 with 8GB of RAM. What type of graphics card is required to run at full speed?

edit retag flag offensive close merge delete

Comments

what model are you using? those seems like pretty good specs to me

Peter Mitrano gravatar imagePeter Mitrano ( 2016-09-20 00:13:27 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-09-29 07:36:53 -0600

Zwilling gravatar image

You can increase the simulation speed by changing the physics values in your world.sdf: http://sdformat.org/spec?ver=1.6&elem...

For example, I use:

<physics type="ode">
  <max_step_size>0.004</max_step_size>
  <real_time_factor>1.2</real_time_factor>
  <real_time_update_rate>300</real_time_update_rate>
</physics>

This way you can simulate a larger time step per iteration and thus increase the real time factor.

edit flag offensive delete link more
0

answered 2016-09-24 07:25:51 -0600

jerryandt gravatar image

Now that I updated the Nvida driver to the latest version, I see a ratio of only 0.17 for the tutorial with the PR2 model and the gas station. http://gazebosim.org/tutorials?tut=ros_roslaunch I am guessing that there must be a check-box somewhere to tell gazebo to use the stream processors on this card.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2016-09-19 20:10:50 -0600

Seen: 249 times

Last updated: Sep 29 '16