Home | Tutorials | Wiki | Issues
Ask Your Question
0

Gazebo no window appear

asked 2016-12-08 07:37:59 -0600

SamanthaTraynor65 gravatar image

updated 2016-12-08 11:38:27 -0600

I've installed Gazebo from sources and now trying to launch it

$ gazebo

$

That's it! No window appear no matter how long I wait. All the files apper to be on their places. I can run this

$ gazebo -h

gazebo -- Run the Gazebo server and GUI.

`gazebo` [options] <world_file>

Gazebo server runs simulation and handles commandline options, starts a Master, runs World update and sensor generation loops. This also starts the Gazebo GUI client in a separate process.

Options:
  -v [ --version ]              Output version information.
  --verbose                     Increase the messages written to the terminal.
  -h [ --help ]                 Produce this help message.
  -u [ --pause ]                Start the server in a paused state.
  -e [ --physics ] arg          Specify a physics engine (ode|bullet|dart|simbody).
  -p [ --play ] arg             Play a log file.
  -r [ --record ]               Record state data.
  --record_encoding arg (=zlib) Compression encoding format for log data 
                                (zlib|bz2|txt).
  --record_path arg             Absolute path in which to store state data.
  --seed arg                    Start with a given random number seed.
  --iters arg                   Number of iterations to simulate.
  --minimal_comms               Reduce the TCP/IP traffic output by gazebo.
  -g [ --gui-plugin ] arg       Load a GUI plugin.
  -s [ --server-plugin ] arg    Load a server plugin.
  -o [ --profile ] arg          Physics preset profile name from the options in
                                the world file.

So, the executable seems to be working. If I try to load the world

$ gazebo worlds/pioneer2dx.world

$

Still nothing. How can I determine what's wrong and fix it?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2016-12-08 11:37:34 -0600

Have you tried running gazebo --verbose to see if any messages are printed?

The first time you run Gazebo, it downloads some models from the internet, so it may take a while. Try giving it some time?

edit flag offensive delete link more

Comments

Well, I can't check it right now 'cause I'm reinstalling Gazebo, but according to htop Gazebo's process won't even start, I guess it starts and immediately shuts down. I'll try your advice when I get the chance.

SamanthaTraynor65 gravatar imageSamanthaTraynor65 ( 2016-12-09 02:17:30 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-12-08 07:37:59 -0600

Seen: 862 times

Last updated: Dec 08 '16