Home | Tutorials | Wiki | Issues
Ask Your Question
0

How to prevent model from moving itself?

asked 2017-02-15 21:16:09 -0500

wangshanren gravatar image

updated 2017-02-17 03:12:07 -0500

I'm using urdf in gazebo to build a walking quadruped robot ,after set the proper inertial (calculated by meshlab followed the tutorials here link text), the model is still moving ,just floating on the ground,acts like someone is pushing it.Also when click my link in gazebo's left panel,some of the bounding box is really wrong. In addition,I just start gazebo without any controller,I found some useful anwsers: link text link text link text link text link text. But none of them fixed my problem.Right now I'm using ROS Indigo with Gazebo 2.x.Here is my urdf files divided into three parts:urdf.xacro, trasmission.xacro and gazebo.xacro.I'v been stuck in this problem for nearly a week.Can anyone help me fix this problem?image descriptionimage descriptionimage descriptionimage description

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-02-21 01:38:11 -0500

wangshanren gravatar image

Well,after three days suffering,I finally make it work,I use my own world files not the default one,then I increase the ODE iters from 50 to 5000,the model is stable.Thanks God! Although I don't know the consequences yet,we'll see!

edit flag offensive delete link more

Comments

Increase ODE iters decreases simulation performances :/

blevesque gravatar imageblevesque ( 2017-05-16 10:44:14 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-02-15 21:16:09 -0500

Seen: 150 times

Last updated: Feb 21