Home | Tutorials | Wiki | Issues
Ask Your Question
1

Enabling gazebo_ros_control plugin changes physics response of entire body

asked 2017-03-07 19:38:34 -0600

dcconner gravatar image

updated 2017-03-11 10:49:10 -0600

I'm using the Nao simulation (https:/github.com/ros-naoqi/nao_robot) with Kinetic and Gazebo 7.

The default launch spawns the robot in the air. The simulation runs slower than real time, but the robot takes almost 30 seconds of simulation time to fall less than 0.2 meters.

If I comment out the invocation of the gazebo_ros_control plugin from the xacro file, then the robot falls to the ground quickly as expected. This slow falling of the main body happens whether I enable any controllers or not.

Any ideas what is causing this issue?

image description (Note the timestamp on image when the robot first touched down.)

Originally the default installation would fall slowly backwards, as shown in the attached image. I fixed the falling backwards by updating some of the dynamics parameters in the urdf, but I have not been able to determine the slow falling.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-03-12 13:05:25 -0600

hsu gravatar image

updated 2017-03-12 13:06:09 -0600

that would be the position controller in ros_control calling SetPosition

Use POSITION_PID instead of POSITION should help.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-03-07 19:38:34 -0600

Seen: 254 times

Last updated: Mar 12