Not Able to use laser scaner in Gazebo

asked 2017-04-12 09:48:01 -0600

Sonia Nazish gravatar image

updated 2017-04-12 10:24:17 -0600

sloretz gravatar image

I am new to Ubuntu,ROS and Gazebo. I have created a simple robot and trying to add laser scanner in it using this tutorial http://gazebosim.org/tutorials?tut=ad... but when I use this code and try to drag robot on plan it start loading and don't give any error message and it also don't show database models "connecting to database models". What i am missing please help me. the code of robot model is this

<?xml version="1.0"?>
<sdf version="1.4">
  <model name="my_robot">
    <static>false</static>
    <link name="chassis">
      <pose>0 0 .1 0 0 0</pose>
      <collision name="collision">
        <geometry>
          <box>
            <size>.4 .2 .1</size>
          </box>
        </geometry>
      </collision>
      <visual name="visual">
        <geometry>
          <box>
            <size>.4 .2 .1</size>
          </box>
        </geometry>
      </visual>
      <collision name="caster_collision">
        <pose>-0.15 0 -0.05 0 0 0</pose>
        <geometry>
          <sphere>
            <radius>.05</radius>
          </sphere>
        </geometry>
        <surface>
          <friction>
            <ode>
              <mu>0</mu>
              <mu2>0</mu2>
              <slip1>1.0</slip1>
              <slip2>1.0</slip2>
            </ode>
          </friction>
        </surface>
      </collision>
      <visual name="caster_visual">
        <pose>-0.15 0 -0.05 0 0 0</pose>
        <geometry>
          <sphere>
            <radius>.05</radius>
          </sphere>
        </geometry>
      </visual>
    </link>
    <link name="left_wheel">
      <pose>0.1 0.13 0.1 0 1.5707 1.5707</pose>
      <collision name="collision">
        <geometry>
          <cylinder>
            <radius>.1</radius>
            <length>.05</length>
          </cylinder>
        </geometry>
      </collision>
      <visual name="visual">
        <geometry>
          <cylinder>
            <radius>.1</radius>
            <length>.05</length>
          </cylinder>
        </geometry>
      </visual>
    </link>
    <link name="right_wheel">
      <pose>0.1 -0.13 0.1 0 1.5707 1.5707</pose>
      <collision name="collision">
        <geometry>
          <cylinder>
            <radius>.1</radius>
            <length>.05</length>
          </cylinder>
        </geometry>
      </collision>
      <visual name="visual">
        <geometry>
          <cylinder>
            <radius>.1</radius>
            <length>.05</length>
          </cylinder>
        </geometry>
      </visual>
    </link>
    <joint type="revolute" name="left_wheel_hinge">
      <pose>0 0 -0.03 0 0 0</pose>
      <child>left_wheel</child>
      <parent>chassis</parent>
      <axis>
        <xyz>0 1 0</xyz>
      </axis>
    </joint>
    <joint type="revolute" name="right_wheel_hinge">
      <pose>0 0 0.03 0 0 0</pose>
      <child>right_wheel</child>
      <parent>chassis</parent>
      <axis>
        <xyz>0 1 0</xyz>
      </axis>
    </joint>
    <include>
      <uri>model://hokuyo</uri>
      <pose>0.2 0 0.2 0 0 0</pose>
    </include>
    <joint name="hokuyo_joint" type="revolute">
      <child>hokuyo::link`</child>
      <parent>chassis</parent>
      <axis>
        <xyz>0 0 1</xyz>
        <limit>
          <upper>0</upper>
          <lower>0</lower>
        </limit>
      </axis>
    </joint>
  </model>
</sdf>
edit retag flag offensive close merge delete

Comments

Are you running the Gazebo first time , by any chance? First time it gets started it needs to download some models from its central server. Perhaps it is the connection problem of some kind.

eugene-katsevman gravatar imageeugene-katsevman ( 2017-04-12 10:58:14 -0600 )edit

there is an extra ` in the hokuyo_joint <child> link name, not sure if that's the problem

iche033 gravatar imageiche033 ( 2017-04-13 12:04:42 -0600 )edit
1

there is an extra ` in the hokuyo_joint child link name, not sure if that's the problem

iche033 gravatar imageiche033 ( 2017-04-13 12:05:28 -0600 )edit