Home | Tutorials | Wiki | Issues
Ask Your Question
0

Mesh is invisible, but I can see it as a collision. DAE model

asked 2017-06-01 16:34:02 -0600

michael1234 gravatar image

updated 2017-06-01 16:38:00 -0600

I am importing a mesh and render it with this code:

     <visual name="top_visual">
      <transparency>0</transparency>
      <pose>0 0 -0.0376785 0 0 1.5707</pose>
      <geometry>
        <mesh>
          <uri>model://velodyne_hdl32/meshes/velodyne_top.dae</uri>
        </mesh>
      </geometry>
    </visual>

It's there but invisible: image description

It's weird, because you can actually see it with view collisions on. image description

edit retag flag offensive close merge delete

Comments

2 Answers

Sort by ยป oldest newest most voted
1

answered 2017-11-27 04:09:01 -0600

Brosseau.F gravatar image

updated 2017-11-30 08:41:09 -0600

Sometimes object exported from blender are not visible (or some of their faces).

To see if the problem is due to that, you can place the camera inside the model (in Gazebo). Once you are inside, if you see the faces, you have to flip normal's direction.

In Blender

  • Select your model
  • Switch to edit mode
  • Select the faces that you want to flip normal's direction
  • In the Shading/UVs panel, select the "flip direction" button
edit flag offensive delete link more
0

answered 2017-11-23 12:42:51 -0600

dafred94 gravatar image

Highly interesting that it's working and being displayed as a collision model! I think that I'm having the same problem and may have found a workaround: export to .obj or .stl instead of .dae .

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-06-01 16:34:02 -0600

Seen: 308 times

Last updated: Nov 30