Home | Tutorials | Wiki | Issues
Ask Your Question
0

Joints of a model are not visible in the joint panel.

asked 2017-07-10 04:43:52 -0600

ozan192 gravatar image

updated 2017-07-10 04:44:47 -0600

I've inserted two models into Gazebo using the GUI. One is the steering cart that is already included with Gazebo, the other is a Velodyne sensor which I created following the tutorials. The Velodyne model has a single revolute joint connecting the base to the top. When I load the Velodyne, I can apply a force to the join to get it to spin however, when I fix it to the cart and save it as a single model, I can no longer see the revolute joint for the Velodyne listed. I can however see the fixed joint I created and also all the joints for the carts wheels.

Is there a proper way to create a new model out of several pre-existing models?

edit retag flag offensive close merge delete

Comments

Do you have an example model file to reproduce the problem?

chapulina gravatar imagechapulina ( 2017-07-10 11:52:27 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-07-10 06:00:02 -0600

ozan192 gravatar image

Apparently, the best way to join to models to create a new one is to create a new model file and include the two previous models. See link below for details.

http://gazebosim.org/tutorials?tut=at...

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-07-10 04:43:52 -0600

Seen: 55 times

Last updated: Jul 10