Home | Tutorials | Wiki | Issues
Ask Your Question
0

getting atlas.launch to run

asked 2013-03-09 15:25:43 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

cannot get atlas.launch to work. I installed 12.04 ubuntu 64 bit. installed ROS and gazebo as per the wiki page. When I ran the drc simulator atlas.launch.

I get the following. nny ideas..

Gazebo multi-robot simulator, version 1.4.0 Copyright (C) 2013 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org

Msg Waiting for master.Msg Waiting for master Msg Connected to gazebo master @ http://127.0.0.1:11345 Msg Publicized address: 10.0.0.10 Xlib: extension "GLX" missing on display ":0". Error [RenderEngine.cc:623] Unable to create glx visual Warning [RenderEngine.cc:87] Unable to create X window. Rendering will be disabled

Msg Connected to gazebo master @ http://127.0.0.1:11345 Msg Publicized address: 10.0.0.10 Xlib: extension "GLX" missing on display ":0". Error [RenderEngine.cc:623] Unable to create glx visual Warning [RenderEngine.cc:87] Unable to create X window. Rendering will be disabled Warning [InsertModelWidget.cc:242] The manifest.xml for a Gazebo model is deprecated. Please rename manifest.xml to model.config for model "/usr/share/drcsim-2.1/gazebomodels/environments/steppingblock" gazebo: /usr/include/boost/smartptr/sharedptr.hpp:418: T* boost::shared_ptr<t>::operator->() const [with T = gazebo::rendering::UserCamera]: Assertion `px != 0' failed.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-03-11 08:49:24 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Thanks! I have a lenovo thinkpad w520 which comes with nvidia quadro card but I did not install any additional drivers. It is currently using the default ubuntu drivers. I did not see nvidia drivers for quadro board on the list of nvidia drivers anyway.

edit flag offensive delete link more

Comments

check if your GPU is properly installed, here is a way: install mesa utils $ sudo apt-get install mesa-utils and then run $ glxgears

AndreiHaidu gravatar imageAndreiHaidu ( 2013-03-11 10:46:21 -0600 )edit
0

answered 2013-03-10 07:04:33 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi,

Most probably you have a graphic card with optimus drive which does not work properly under linux. You could try the bubmlebee project see if it works with that, if not I think you have to uninstall the nvidia drivers and just use the default ones from ubuntu. This meaning that the computer is going to use the onboard GPU not the dedicated one, which will be a lot slower.

Cheers, Andrei

edit flag offensive delete link more

Comments

Thanks, I was having a similar problem and your suggestion of trying the bumblebee project fixed it.

Airuno2L gravatar imageAiruno2L ( 2013-11-07 07:55:21 -0600 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-03-09 15:25:43 -0600

Seen: 696 times

Last updated: Mar 11 '13