Home | Tutorials | Wiki | Issues
Ask Your Question
0

Prevent spawned robot model from moving

asked 2017-10-03 04:47:31 -0500

Fiddle gravatar image

Hi, I want to control the robot model that I spawned using spawn_model script, but after spawning it starts to rotate slightly, and I think this causes problems with Moveit package, because when I try to execute planned path I get this error:

[ERROR] [1507023800.853643333, 2796.811000000]: 
Invalid Trajectory: start point deviates from current robot state more than 0.01
joint 'Kuka_kr3__base_revolute': expected: -0.441804, current: -0.420193

GIF

How can I stop such movement?

edit retag flag offensive close merge delete

Comments

It might be a problem with the controller you are using in the simulation. I had a similar problem with the controller of a robot gripper that caused the gripper to move without giving any commands. Which controller are you using? Can you post the code of the UpdateChild() function?

wentz gravatar imagewentz ( 2017-10-05 06:54:21 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-10-05 02:56:55 -0500

Fiddle gravatar image

The answer is to set damping and friction properties in URDF correctly

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2017-10-03 04:47:31 -0500

Seen: 70 times

Last updated: Oct 05