Home | Tutorials | Wiki | Issues
Ask Your Question
0

cannot launch the Gazebo 8 and get error "undefined symbol". [closed]

asked 2017-10-09 14:04:34 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

When I launch the Gazebo 8, I got the error below. gzserver: symbol lookup error: /usr/lib/x86_64-linux-gnu/libgazebo_sensors.so.8: undefined symbol: _ZN8ignition4msgs12ImageStamped17default_instance_E

I have no trouble before, but I tried to update Gazebo dependencies, the error shows up. I removed all the palcages and reinstall, nothing works. Thanks.

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by whrobot
close date 2017-10-15 09:13:52.257102

Comments

are you installing ignition-msgs from source? We recently removed the *Stamped msgs in the `default` branch. You may need to revert back to the release version of ign-msgs

iche033 gravatar imageiche033 ( 2017-10-09 17:38:42 -0500 )edit

Thanks. Yes, your guess is right. I installed ignition-msgs from source and then had this error. But would you please talk a little more about the reverting to the release version of ign-msgs? I am new to Gazebo, and I tried to uninstall the ign-msgs, and it seems to be unsuccessful. I did as follows to remove and reinstall, but no luck. sudo apt-get remove '.*gazebo.*' '.*sdformat.*' '.*ignition-math.*' '.*ignition-msgs.*' '.*ignition-transport.*' Many thanks.

whrobot gravatar imagewhrobot ( 2017-10-09 18:32:53 -0500 )edit

if you installed from source then you'll need to go to your build folder and uninstall using `make uninstall`. After that, checkout ign-msgs0 branch: `hg up ign-msgs0 -C`, and make install again. More info in the ign-msgs README.md file: https://bitbucket.org/ignitionrobotics/ign-msgs/src/39d37f16076309eacb06c35ac441518e77f649d3/README.md?at=ign-msgs0&fileviewer=file-view-default

iche033 gravatar imageiche033 ( 2017-10-10 11:56:27 -0500 )edit

I uninstalled the ign-msgs as you told, I tried to launch Gazebo from terminal, the previous error disappeared, but the Gazebo cannot start and it crashed. Then, I installed the ign-msg0. Cloned it from Bitbucket and built and make. After that, the same error come back. "gzserver: symbol lookup error: /usr/lib/x86_64-linux-gnu/libgazebo_sensors.so.8: undefined symbol: _ZN8ignition4msgs12ImageStamped17default_instance_E " Thanks you again.

whrobot gravatar imagewhrobot ( 2017-10-10 14:50:11 -0500 )edit

can you verify that you're on the `ign-msgs0` branch in ign-msgs? Make sure there're no left over files from previous source installs. Also check that the ign-msgs being linked by gazebo points to the one you installed: `ldd /usr/lib/x86_64-linux-gnu/libgazebo_sensors.so | grep ignition-msgs`

iche033 gravatar imageiche033 ( 2017-10-10 18:36:35 -0500 )edit

Hi iche033. I read about the Mercurial tool and do as follows and am sure I installed correctly. I cloned the repository and then "hg pull && hg update ign-msgs0" . make and install it. I picked some of record showing that "Linking CXX shared library libignition-msgs0.so"... "Built target ignition-msgs0"... the last line is " Installing: /usr/local/share/ignition/msgs0.yaml". Finally, I use "ldd /usr/lib/x86_64-linux-gnu/libgazebo_sensors.so.8 | grep ignition-msgs", I still cannot get it work.

whrobot gravatar imagewhrobot ( 2017-10-12 18:03:30 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-10-15 09:13:24 -0500

whrobot gravatar image

I tried to remove everything about Gazebo and ign-msgs (uninstall from source), then install Gazebo 8 again from the source and deb. file. Neither works. The last time, I uninstalled once again, then install Gazebo 7, (just use sudo apt install gazebo7) finally it works. hope other features can be used too. keep using and testing. Thanks for iche033's help.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2017-10-09 14:04:34 -0500

Seen: 46 times

Last updated: Oct 15