Home | Tutorials | Wiki | Issues
Ask Your Question
0

gazebo shadow with transparent texture

asked 2017-10-20 09:23:34 -0600

yjy765 gravatar image

Hi, I imported the dae file which is made from Blender.

The dae file contains just simple plane with texture and transparency

The model itself works well, but shadow does not reflect the transparency

Please see below image

image description

How can I make shadow reflect the transparent part?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-10-20 14:26:27 -0600

chapulina gravatar image

updated 2017-10-25 10:02:51 -0600

Unfortunately, I don't think there is a way of fixing it right now, feel free to ticket an issue on Gazebo:

https://bitbucket.org/osrf/gazebo/iss...

The shadows right now don't seem to be taking the texture's transparency into account, so the shadows we see are from the original mesh. You can check the original mesh by choosing View -> Collisions:

image description

edit flag offensive delete link more

Comments

Thank you for your answer. But, I saw a pine tree model(https://bitbucket.org/osrf/gazebo_models/src/default/pine_tree/) gives a reasonable shadow. Do you know how did they do that?

yjy765 gravatar imageyjy765 ( 2017-10-23 00:03:46 -0600 )edit

I updated the answer with a pine tree example

chapulina gravatar imagechapulina ( 2017-10-24 21:09:48 -0600 )edit

I see, I thought the small shadows take the transparency into account before looking at your image. Thanks. I created the issue

yjy765 gravatar imageyjy765 ( 2017-10-25 05:09:27 -0600 )edit
1

you should be able to take the shadow caster shaders I added in this gazebo_models PR and apply them to your model: https://bitbucket.org/osrf/gazebo_models/pull-requests/312

iche033 gravatar imageiche033 ( 2017-11-09 14:09:52 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2017-10-20 09:23:34 -0600

Seen: 428 times

Last updated: Oct 25 '17