Home | Tutorials | Wiki | Issues
Ask Your Question
1

libbullet error installing drcsim-2.2

asked 2013-03-12 23:07:33 -0500

dcconner gravatar image

updated 2013-03-12 23:08:08 -0500

I have openrave installed, which uses libbullet-2.81

When I try to install drcsim-2.2 I get the following errors

Errors were encountered while processing:
 /var/cache/apt/archives/libbullet_2.81-1ppa1~precise_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried again:

Groovy$sudo apt-get install drcsim
Reading package lists... Done
Building dependency tree       
Reading state information... Done
drcsim is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 gazebo : Depends: libbullet but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Groovy$sudo apt-get -f install 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libbullet
The following NEW packages will be installed:
  libbullet
0 upgraded, 1 newly installed, 0 to remove and 9 not upgraded.
3 not fully installed or removed.
Need to get 0 B/906 kB of archives.
After this operation, 2,289 kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
(Reading database ... 340839 files and directories currently installed.)
Unpacking libbullet (from .../libbullet_2.81-1ppa1~precise_amd64.deb) ...
dpkg: error processing /var/cache/apt/archives/libbullet_2.81-1ppa1~precise_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/libBulletSoftBody.so', which is also in package libbullet2.80 2.80.2-ubuntu1~precise1
Errors were encountered while processing:
 /var/cache/apt/archives/libbullet_2.81-1ppa1~precise_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Suggestions?

edit retag flag offensive close merge delete

Comments

1

Gazebo pulls in libbullet-2.81 from the OSRF repository. Unfortunately it conflicts with the existing bullet version you have installed which looks like it's libbullet-2.80. You'll probably have to uninstall that before installing gazebo.

iche033 gravatar imageiche033 ( 2013-03-13 03:24:11 -0500 )edit

I neglected to include the part where sudo apt-get remove libbullet was giving me an error after this. Removing libbullet before trying the -f install on another machine avoided this issue, so drcsim-2.2 is working on that machine.

dcconner gravatar imagedcconner ( 2013-03-13 08:29:06 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-03-13 08:05:04 -0500

Jose Luis Rivero gravatar image

This should be consider as a bug. I have filed a ticket.

As iche033 comments, a workaround is to uninstall system libbullet and install OSRF provided libbullet. What is going to happen with openrave, if it was installed from packages, will depend upon the package dependencies. If it depends on exactly libbullet-2.80, we should look at it carefully because probably the fix is not trivial. Feel free to start a ticket if this is the case.

Otherwise, installing it on top of OSRF libbullet should work. Thanks for reporting.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-03-12 23:07:33 -0500

Seen: 385 times

Last updated: Mar 13 '13