Home | Tutorials | Wiki | Issues
Ask Your Question

Wheels are rotating but robot is not moving

asked 2017-11-17 19:33:01 -0600

_npaul gravatar image

updated 2017-11-19 19:24:39 -0600

I am working on a simple simulation that I cannot seem to get working. I am able to send a Twist message to the robot and the robot's wheels will turn but it doesn't move anywhere. I tried setting the mu values to the wheels to very high values (100, 10000, etc.) but it has no effect.

image description

Snippet from urdf macro:

    <gazebo reference="${lr}_wheel">
      <mu1 value="1.0"/>
      <mu2 value="1.0"/>
      <kp  value="10000000.0" />
      <kd  value="1.0" />
      <fdir1 value="1 0 0"/>

The full source code I am using is on my GitHub here: https://github.com/nick-paul/mybot_ga...

To reproduce the error, clone the repo and run

   roslaunch mybot_gazebo mybot_world.launch

then send a Twist message to /mybot/cmd_vel.

Thanks for any help!

Edit 1:

It looks like the wheels are making contact. If I set the Twist to a high value and let it run for a little while, the robot will begin to slide around very slowly. You can see that it has moved a little bit every time this GIF loops:


edit retag flag offensive close merge delete


Maybe the wheel is not big enough to touch the ground? You can visualize contacts by choosing View -> Contacts on the top menu.

chapulina gravatar imagechapulina ( 2017-11-18 15:25:29 -0600 )edit

It looks like the wheels are making contact: https://image.ibb.co/btuvDR/contact_points.gif After letting the simulation run for a little while, the robot will begin to slide very slowly.

_npaul gravatar image_npaul ( 2017-11-19 19:21:20 -0600 )edit

I am bothered by the same problem. What is slightly different is that my wheels will not have slight slide. Can you solve it now?

duhyu1 gravatar imageduhyu1 ( 2018-04-03 04:06:25 -0600 )edit

Did you solve the problem? I have a simular issue, but increasing the friction did not work for me:(

schokkobaer gravatar imageschokkobaer ( 2019-02-01 08:16:41 -0600 )edit

I suffered the same issue with ROS Kinetic and Gazebo 7. I fixed it with installing Gazebo 9. If someone has the same issue, try to upgrade Gazebo. I followed the instructions described in https://medium.com/@abhiksingla10/set...

damul73 gravatar imagedamul73 ( 2019-03-20 07:59:45 -0600 )edit

I suffered a similar issue with ROS Kinetic and Gazebo 7.0.0. Funny thing was that it happened only in the direction of X and Y axes. When I upgraded to 7.16, the problem went away!

thesidjway gravatar imagethesidjway ( 2019-09-08 04:52:05 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2018-08-28 07:32:31 -0600

Nurul Karim gravatar image

updated 2018-08-28 07:34:05 -0600

I think you can try increasing your friction of the world surface.. by making


I think you will see the effect. It seems your wheels moving but not making enough friction to move but rather slipping.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools



Asked: 2017-11-17 19:33:01 -0600

Seen: 2,492 times

Last updated: Aug 28 '18