Home | Tutorials | Wiki | Issues
Ask Your Question
0

Pepper model falls at startup

asked 2018-01-10 06:59:47 -0500

fqez gravatar image

Hello!

I've been recently playing with the official ROS simulated Pepper in Gazebo and I'm facing a little problem. When I launch the example (using roslaunch) and start the simulation, the robot starts falling very slowly ( here's a video showing the problem).

The only error trace that roslaunch shows is:

[ERROR] [1515588569.033999191]: GazeboRosDiffDrive Plugin missing <legacyMode>, defaults to true
This setting assumes you have a old package, where the right and left wheel are changed to fix a former code issue
To get rid of this error just set <legacyMode> to false if you just created a new package.
To fix an old package you have to exchange left wheel by the right wheel.
If you do not want to fix this issue in an old package or your z axis points down instead of the ROS standard defined in REP 103
just set <legacyMode> to true.

I'm working with ROS Kinetic and Gazebo 7.9.0. The model I'm using is the one included in the debian packages for ROS kinetic.

Am I doing something wrong? Or am I missing a package or something?

Thanks in advance.

edit retag flag offensive close merge delete

Comments

The GazeboRosDiffDrive error seems unrelated to the problem. Could you please specify what packages are you installing and what roslauch command are you using? Thanks.

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2018-01-24 10:41:37 -0500 )edit

I too have the same issue. I am using the pepper_gazebo_plugin package (https://github.com/ros-naoqi/pepper_virtual). I tried using both the launch files (pepper_gazebo.launch and pepper_gazebo_plugin_Y20.launch) but in both the worlds the same issue persists. I think there is some problem with the urdf (https://groups.google.com/d/msg/ros-sig-aldebaran/GN85jo_2Ano/aUckNtDTCAAJ). Not sure how to fix it though.

akhadke gravatar imageakhadke ( 2018-02-22 17:45:40 -0500 )edit

Hi, sorry for the late reply.. I've installed every pepper gazebo related package from ROS kinetic. And the command I'm starting the simulation with is the following: roslaunch pepper_gazebo_plugin pepper_gazebo_plugin_Y20.launch as shown in the video. Thanks!!

fqez gravatar imagefqez ( 2018-03-20 08:09:22 -0500 )edit

Is there no solution then? Based on your link akhadke.

fqez gravatar imagefqez ( 2018-03-21 12:46:12 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-03-12 05:41:16 -0500

mingfei gravatar image

Hi, this error (GazeboRosDiffDrive Plugin missing <legacymode>) can be fixed by modifying the Pepper urdf file pepperGazebo.xacro:

To change the Drive controller part in pepperGazebo.xacro as follows:

Before:

<gazebo>
  <plugin name="differential_drive_controller" filename="libgazebo_ros_diff_drive.so">
    <alwaysOn>true</alwaysOn>
    <updateRate>100</updateRate>
    <robotNamespace>/</robotNamespace>
    <leftJoint>WheelFL</leftJoint>
    <rightJoint>WheelFR</rightJoint>
    <wheelSeparation>0.170</wheelSeparation>
    <wheelDiameter>0.140</wheelDiameter>
    <torque>36.9</torque>
    <commandTopic>cmd_vel</commandTopic>
    <odometryTopic>odom_diffdrive</odometryTopic>
    <odometryFrame>odom</odometryFrame>
    <robotBaseFrame>base_footprint</robotBaseFrame>
  </plugin>
</gazebo>

Chang to:

<gazebo>
  <plugin name="differential_drive_controller" filename="libgazebo_ros_diff_drive.so">
    <alwaysOn>true</alwaysOn>
    <legacyMode>false</legacyMode>
    <updateRate>100</updateRate>
    <robotNamespace>/</robotNamespace>
    <leftJoint>WheelFL</leftJoint>
    <rightJoint>WheelFR</rightJoint>
    <wheelSeparation>0.170</wheelSeparation>
    <wheelDiameter>0.140</wheelDiameter>
    <torque>36.9</torque>
    <commandTopic>cmd_vel</commandTopic>
    <odometryTopic>odom_diffdrive</odometryTopic>
    <odometryFrame>odom</odometryFrame>
    <odometrySource>world</odometrySource>
    <publishTf>1</publishTf>
    <rosDebugLevel>na</rosDebugLevel>
    <wheelAcceleration>0</wheelAcceleration>
    <wheelTorque>5</wheelTorque>
    <robotBaseFrame>base_link</robotBaseFrame>
    <publishWheelTF>false</publishWheelTF>
    <publishWheelJointState>false</publishWheelJointState>
  </plugin>
</gazebo>

You can find the correct source code (error free) from my personal repository.

As for the robot falling down, I don't how to fix it yet.

edit flag offensive delete link more

Comments

I will try that, thank you very much!

fqez gravatar imagefqez ( 2018-03-20 08:10:26 -0500 )edit

could you please submit the fix to the pepper repository, in the case you haven't do that?

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2018-04-03 13:50:39 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-01-10 06:59:47 -0500

Seen: 203 times

Last updated: Mar 12