Home | Tutorials | Wiki | Issues
Ask Your Question
0

sudo apt-get install gazebo > gazebo : Depends: ... but it is not installable

asked 2013-03-15 03:40:31 -0500

updated 2013-03-15 04:33:55 -0500

Hi, How can i fix this problem? tnx

mohsen@mohsen-ThinkPad-R500:~$ sudo apt-get install gazebo

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

gazebo : Depends: libboost-thread1.49.0 but it is not installable

      Depends: libboost-signals1.49.0 but it is not installable

      Depends: libboost-system1.49.0 but it is not installable

      Depends: libboost-filesystem1.49.0 but it is not installable

      Depends: libboost-program-options1.49.0 but it is not installable

      Depends: libboost-regex1.49.0 but it is not installable

      Depends: libboost-iostreams1.49.0 but it is not installable

      Depends: libcegui-mk2-0.7.6 but it is not installable

E: Unable to correct problems, you have held broken packages.

mohsen@mohsen-ThinkPad-R500:~$

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-03-15 06:40:16 -0500

Jose Luis Rivero gravatar image

Boost1.49.0 is listed as a dependency for gazebo in the quantal version. Be sure you are not running a precise distribution using a quantal sources.list in /etc/apt/sources.list.d/.

If that is not the reason, some extra information is would be good:

  1. Ubuntu distribution being used and architecture (32/64bits)
  2. Clean installation or upgrading?
  3. Output from > grep osrfoundation > /etc/apt/sources.list.d/*.list
edit flag offensive delete link more

Comments

tnx! (in gazebo-latest.list >> deb http://packages.osrfoundation.org/gazebo/ubuntu quantal main) (in ros-latest.list >>deb http://packages.ros.org/ros/ubuntu precise main) i change it to0 "precise" and trying to re install with synaptic. it's work

Mohsen Hk gravatar imageMohsen Hk ( 2013-03-18 18:55:05 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2013-03-15 03:40:31 -0500

Seen: 738 times

Last updated: Mar 15 '13