Home | Tutorials | Wiki | Issues
Ask Your Question
0

Ignition-math installing

asked 2018-03-11 07:40:42 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I am trying to install ignition math, but if I install it from the default branch it is seems to be already on the version 5.0. It is not recognized as by the other dependences as they expect the version 4.0. Is there I way to install the 4.0 which is not from the git repository or a branch with the stable version of the 4.0?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-03-12 10:04:36 -0500

You can install from source by moving to the version 4 branch before building:

hg up ign-math4

Or you can install from debian packages on Ubuntu:

sudo sh -c 'echo "deb http://packages.osrfoundation.org/gazebo/ubuntu-stable `lsb_release -cs` main" > /etc/apt/sources.list.d/gazebo-stable.list'
deb http://packages.osrfoundation.org/gazebo/ubuntu-stable xenial main
wget http://packages.osrfoundation.org/gazebo.key -O - | sudo apt-key add -
sudo apt-get update
sudo apt install libignition-math4*
edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-03-11 07:40:42 -0500

Seen: 58 times

Last updated: Mar 12