/cmd_VEL topic is missing edit

asked 2018-04-09 15:45:45 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

hi ,

i have installed (again) Indigo with its default Gazebo as well as Hector_quadrotor link text. I cant find the topic /cmd_vel in order to send a flying command. also , i did install ardrone_autonomy plus tum_simulator and the same situation . here is a list of the topics when launching roslaunch cvg_sim_gazebo ardrone_testworld.launch according to link text:

rostopic list

/aerodynamics/wrench

/altimeter

/altimeter/parameter_descriptions

/altimeter/parameter_updates

/clock

/command/motor

/command/wrench

/fix

/fix/position/parameter_descriptions

/fix/position/parameter_updates

/fix/status/parameter_descriptions

/fix/status/parameter_updates

/fix/velocity/parameter_descriptions

/fix/velocity/parameter_updates

/fix_velocity

/gazebo/link_states

/gazebo/model_states

/gazebo/parameter_descriptions

/gazebo/parameter_updates

/gazebo/set_link_state

/gazebo/set_model_state

/ground_truth/state

/joint_states

/magnetic

/magnetic/parameter_descriptions

/magnetic/parameter_updates

/motor_pwm

/motor_status

/pressure_height

/propulsion/wrench

/quadro/trigger

/raw_imu

/raw_imu/accel/parameter_descriptions

/raw_imu/accel/parameter_updates

/raw_imu/bias

/raw_imu/rate/parameter_descriptions

/raw_imu/rate/parameter_updates

/raw_imu/yaw/parameter_descriptions

/raw_imu/yaw/parameter_updates

/rosout

/rosout_agg

/sonar_height

/sonar_height/parameter_descriptions

/sonar_height/parameter_updates

/supply

/tf

/tf_static

/wind

had anyone seen such a thing before ? ps: i think in both cases i saw the same topics (hector and ardrone).

thanks in advance

edit retag flag offensive close merge delete

Comments

Did you enable the motors as it says in the tutorial: rosservice call /enable_motors "enable: true"

Raskkii gravatar imageRaskkii ( 2018-04-10 02:16:47 -0600 )edit