Home | Tutorials | Wiki | Issues
Ask Your Question
0

Invalid Mesh File error - "" is not a valid mesh file

asked 2018-04-12 06:11:14 -0500

robotlab gravatar image

updated 2018-04-14 01:11:15 -0500

When I import a STL model in Gazebo 7 Model Editor I receive the following error:

"" is not a valid mesh file. Please select another file for [visual]

image description

The file has been exported from SolidWorks in ASCII format. I have tried with several models. One model is attached below, rename it from jpg to STL (because of upload requirements).C:\fakepath\table.jpg

Also no link appears in the Model tab

image description

Any suggestions to why I receive this error and how to make the links work?

Setup:

  • Gazebo 7.0 (ROS kinetic)
  • Ubuntu 16.04

Edit 1:

I may have found a bug or two.

Even though the Uri for the STL file is in the text field in the Visual tab, then it gives me the error. If I browse to the STL in the exact same path, then it can now find it again.

Additionally, I noticed that when I go to the Link tab and enter a value for pose and hit Enter key, then it deletes both Uri paths in Visual and Collision.

Change x pose to 0.1 and hit Enter key

image description

Error that the mesh file cannot be found

image description

Uri to the STL is now empty

image description

Edit 2:

Added small video with test in from Gazebo 9.0.0. The error appears after hitting the Enter key when setting the pose of the object.

https://goo.gl/9bULYj

edit retag flag offensive close merge delete

Comments

Can you post you stl model file?

nkoenig gravatar imagenkoenig ( 2018-04-13 10:00:03 -0500 )edit

I have attached one of my STLs above (renamed to jpg because of upload requirements). I have added some additional information to my original post as I came across some bugs in the UI when editing the properties of a model.

robotlab gravatar imagerobotlab ( 2018-04-13 12:34:42 -0500 )edit

I've seen this issue before (the URI disappearing from the inspector). I just tried to reproduce it now on Gazebo 8 and couldn't, so I suspect it may have been solved in newer versions... You could try upgrading from 7

chapulina gravatar imagechapulina ( 2018-04-13 14:13:21 -0500 )edit

I just tried with Gazebo 9.0.0 and experience the same, here is a small video https://goo.gl/9bULYj. I will also try with Gazebo 8. Btw, I am using the Gazebo versions from the ROS kinetic dist, not sure if this makes a difference.

robotlab gravatar imagerobotlab ( 2018-04-14 01:10:47 -0500 )edit
1

Ahh I know what's going on now, when you press enter, the `Reset` button is focused and it is triggered. There is a bug that resetting clears the URI. Would you mind ticketing an issue? https://bitbucket.org/osrf/gazebo/issues/

chapulina gravatar imagechapulina ( 2018-04-15 11:04:22 -0500 )edit

Ah ok, thanks a lot for figuring out what was going on :) Sure thing, will create an issue. Thanks again. Cheers

robotlab gravatar imagerobotlab ( 2018-04-15 12:54:52 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-04-13 09:43:40 -0500

Raskkii gravatar image

Can you try exporting from SolidWorks in other formats? The Gazebo model tutorial says:

Gazebo requires that mesh files be formatted as STL, Collada or OBJ, with Collada and OBJ being the preferred formats.

edit flag offensive delete link more

Comments

I will try with some other formats, but I noticed that my STL files do work, however, Gazebo randomly deletes the Uri when I change other values in the interface. See my original post for updated information.

robotlab gravatar imagerobotlab ( 2018-04-13 12:29:53 -0500 )edit

As seen in the comments above, the problem comes from a bug in the UI, which resets the Uri for the CAD model.

robotlab gravatar imagerobotlab ( 2018-04-16 12:19:39 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-04-12 06:10:39 -0500

Seen: 103 times

Last updated: Apr 14