How do I get the IMU to use the NED reference frame?

asked 2018-05-17 22:14:24 -0500

MartinDeegan gravatar image

I'm not quite sure if the imu orientation_reference_frame is the correct thing to set, but I've set my IMU to use the following options. When testing, I've noticed that the IMU is not outputting in a NED reference frame. A counter clockwise rotation about Z is positive when it should be negative in the NED frame. Also, the accelerometer is reading +9.8 at rest when it should be -9.8 in a NED reference frame.

 <sensor type="imu" name="imu_sensor">
        <always_on>true</always_on>
        <update_rate>100.0</update_rate>
        <imu>
          <orientation_reference_frame>
            <localization>NED </localization>
          </orientation_reference_frame>
        </imu>
</sensor>

I've also set these world settings:

<spherical_coordinates>
      <surface_model>EARTH_WGS84</surface_model>
      <world_frame_orientation>NED</world_frame_orientation>
      <latitude_deg>42.2546</latitude_deg>
      <longitude_deg>-83.7648</longitude_deg>
      <elevation>281</elevation>
      <heading_deg>0</heading_deg>
    </spherical_coordinates>
edit retag flag offensive close merge delete