Home | Tutorials | Wiki | Issues
Ask Your Question
0

Actor and LiDAR sensor problems

asked 2018-06-06 06:51:31 -0500

mpc gravatar image

I have been trying to experiment with the actors to create a scripted animation.

My goal is to create a simulation with a automated drone and small airplane flying in a fixed preplanned path. The drone must be able to perceive the plane using RGB, LiDAR and Ultrasound sensors. Based on the actor guide my understanding was that I could use the actor class to create this simulation: http://gazebosim.org/tutorials?tut=ac...

I started out testing the actor with the cube example, added a few more blocks and the standard LiDAR (hokoyo). When the LiDAR is loaded into the environment, the actor (cube) seems to freeze from time to time and then restarts. The cube does not seem to be perceived by the LiDAR rendering: image description

I am not sure if my configuration is wrong or LiDAR should not be used together with the actor.

My setup is Ubuntu 18.04 and Gazebo multi-robot simulator, version 9.1.0 (installed via the ROS package manager)

My other option is to create a model without gravity and a code c++ plugin to perform what the actor basically does. I am hoping I can use the actor for my project since it seems like a nice addition to Gazebo.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-06-07 12:08:05 -0500

I can reproduce the issue, it looks like a bug to me. It only happens with the box actor, the human actor works fine.

Would you mind ticketing an issue? Thanks!

https://bitbucket.org/osrf/gazebo/issues

edit flag offensive delete link more

Comments

mpc gravatar imagempc ( 2018-06-14 06:58:57 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-06-06 06:51:31 -0500

Seen: 192 times

Last updated: Jul 12