Errors while adding ros_control and diff_drive_plugin

asked 2018-06-10 07:07:45 -0500

Rik3214 gravatar image

updated 2018-06-12 08:06:01 -0500

Jose Luis Rivero gravatar image

Well, title says it all...I am unable to load the model in gazebo...the model loads and then crashes. I will attach both my URDF and my Error Log. Please help me out!

My URDF code:

C:\fakepath\robo.sdf

My Error Log

rik@rik-Predator-G3-572:~$ gazebo
Warning [parser.cc:536] XML Attribute[value] in element[horizontal_fov] not defined in SDF, ignoring.
[FATAL] [1528632393.834639326]: You must call ros::init() before creating the first NodeHandle
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []
[ERROR] [1528632393.990849449]: [registerPublisher] Failed to contact master at [:0].  Retrying...
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []
Couldn't find an AF_INET address for []
edit retag flag offensive close merge delete

Comments

Hello: I changed the uppercases and made some editions. There are clear errors in the log, I would use them as a guide to start investigating what is failing. Seems like you want to use ROS without using rosrun or roslaunch. I would recommend to follow the tutorials: http://gazebosim.org/tutorials?cat=connect_ros

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2018-06-12 08:09:12 -0500 )edit