Home | Tutorials | Wiki | Issues
Ask Your Question
0

my model is not showing in gazebo

asked 2018-06-11 07:35:54 -0500

rohit18mittal gravatar image

updated 2018-06-11 11:52:31 -0500

my model is not showing under insert tab, here i am showing step by step procedure of what i have done

Step 1 I want test1 model to be shown up in gazebo C:\fakepath\Screenshot from 2018-06-11 17:54:57.png

Step 2 I have sdf file and config file, also .dae file in meshes folder C:\fakepath\Screenshot from 2018-06-11 17:58:15.png

Step 3 screen shot of config and sdf file C:\fakepath\Screenshot from 2018-06-11 17:59:49.png C:\fakepath\Screenshot from 2018-06-11 18:01:31.png

Step 4 Finally in step 4 when i open gazebo then under insert tab this is what i get C:\fakepath\Screenshot from 2018-06-11 18:02:29.png

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-06-11 11:57:09 -0500

Here are some problems I spotted:

  • The config file cannot have an arbitrary name, it must be called model.config, you're calling it camera.config

  • The root element of the .sdf file must be <model>, you currently have <world>

When you launch gazebo, run it in verbose mode so you can see error messages that should give you more clues:

gazebo --verbose
edit flag offensive delete link more

Comments

thanks for your reply, i will correct it

rohit18mittal gravatar imagerohit18mittal ( 2018-06-12 05:08:25 -0500 )edit
1

thanks a ton chapulina, my model is now showing in gazebo Thank you very much

rohit18mittal gravatar imagerohit18mittal ( 2018-06-12 05:52:46 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-06-11 07:35:54 -0500

Seen: 35 times

Last updated: Jun 11