Home | Tutorials | Wiki | Issues
Ask Your Question
0

Can't start gazebo (urdf model)

asked 2018-06-24 06:34:51 -0600

DoctorUlysses gravatar image

updated 2018-06-24 07:04:44 -0600

I'm trying to launch gazebo using roslaunch, but somewhy I'm getting the errors.

Segmentation fault (core dumped) [gazebo_gui-3] process has died [pid 3112, exit code 139, cmd /opt/ros/kinetic/lib/gazebo_ros/gzclient __name:=gazebo_gui __log:=/home/ulysses/.ros/log/807b3030-77a1-11e8-bd9d-08002782662e/gazebo_gui-3.log]. log file: /home/ulysses/.ros/log/807b3030-77a1-11e8-bd9d-08002782662e/gazebo_gui-3.log Segmentation fault (core dumped) [gazebo-2] process has died [pid 3107, exit code 139, cmd /opt/ros/kinetic/lib/gazebo_ros/gzserver -e ode /home/ulysses/catkin_ws/src/robotino_gazebo/worlds/robotino.world __name:=gazebo __log:=/home/ulysses/.ros/log/807b3030-77a1-11e8-bd9d-08002782662e/gazebo-2.log]. log file: /home/ulysses/.ros/log/807b3030-77a1-11e8-bd9d-08002782662e/gazebo-2.log ^C[spawn_urdf-4] killing on exit

Here is my launch file:

<launch> <include file="$(find gazebo_ros)/launch/empty_world.launch"> <arg name="world_name" value="$(find robotino_gazebo)/worlds/robotino.world"/> </include>

<node name="spawn_urdf" pkg="gazebo_ros" type="spawn_model" output="screen" args="-file $(find robotino_description)/urdf/robotino.urdf -urdf -model robotino"/>

</launch>

and another error:

rosrun gazebo_ros gazebo [ INFO] [1529841834.342204778]: Finished loading Gazebo ROS API Plugin. [ INFO] [1529841834.343897101]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting... /opt/ros/kinetic/lib/gazebo_ros/gazebo: 46: kill: invalid signal number or name: SIGINT

Last time I have launched this successfully, but because of something I can't do this now. There is no gazebo-2*.log as well, but I can provide any file which can help you to help me

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2018-06-28 06:36:39 -0600

DoctorUlysses gravatar image

SOLVED: just turn off 3d acceleration in virtualbox

edit flag offensive delete link more
0

answered 2018-06-26 03:45:38 -0600

Raskkii gravatar image

It might help if you launched it like this:

  • Open terminal: rosrun gazebo_ros gazebo /path/to/robotino.world --verbose
  • Open another terminal: roslaunch /your/launch_file.launch

Also, you'd have to remove (or comment out) the
<include file="$(find gazebo_ros)/launch/empty_world.launch"> <arg name="world_name" value="$(find robotino_gazebo)/worlds/robotino.world"/> </include>
from your launch file.

edit flag offensive delete link more

Comments

Thanks for the answer! But I can't launch gazebo as well: https://imgur.com/a/wWdF2H6 (somewhy is here < / p > at the end of the link, which must not be here)

DoctorUlysses gravatar imageDoctorUlysses ( 2018-06-26 17:01:07 -0600 )edit

Does Gazebo launch in the default state? Just $ gazebo

MRhinelander gravatar imageMRhinelander ( 2018-06-27 10:38:16 -0600 )edit

No, Cannot access memory at address 0x0 https://imgur.com/a/rUaLK1k , I'm running on virtualbox, I think it is because of that. On the actual machine it runs properly. But I don't know what I must do in this situation, to run normally on the virtual machine.

DoctorUlysses gravatar imageDoctorUlysses ( 2018-06-27 12:20:52 -0600 )edit

https://answers.ros.org/question/223823/segmentation-fault-in-gazebo/?answer=223843#post-id-223843 Maybe this will be helpful

MRhinelander gravatar imageMRhinelander ( 2018-06-27 13:50:04 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-06-24 06:34:51 -0600

Seen: 471 times

Last updated: Jun 28