Home | Tutorials | Wiki | Issues
Ask Your Question
0

Clouds from screen is not visible in camera image

asked 2018-08-06 08:45:35 -0500

mpc gravatar image

I am trying to model a camera sensor in Gazebo and pass the image to ROS: image description

My problem is that the clouds from the screen do not appear in the camera image. Currently, I am unsure if this is the normal operation of the libgazebo_ros_camera.so or this is an error. I would like to have a camera where clouds from the screen are available in the image.

I am currently running Gazebo 9.3.0 and ROS melodic.

First I want to find out why the clouds do not appear in the camera image and second how to update the plugin so they are available.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-08-06 11:54:00 -0500

This is a known issue, you can vote for it and it would be great if you could dig to figure out what exactly is the problem and possible solution.

edit flag offensive delete link more

Comments

1

Thank you very much for the input :-) I think the test case the other guys found is a bit easier to work with and also shows it is not a ROS camera plugin issue. I think it might be related to this issue: https://bitbucket.org/osrf/gazebo/issues/693/test-setting-skyx-mode-during-a-render But I am not sure!, since my experience with the gazebo code is currently not that extensive. I will try to check out a separate version of Gazebo on my computer and see if I can fix it over the coming months.

mpc gravatar imagempc ( 2018-08-07 03:59:36 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-08-06 08:45:35 -0500

Seen: 36 times

Last updated: Aug 06