Home | Tutorials | Wiki | Issues
Ask Your Question
0

Unable to rotate ground_plane

asked 2018-11-05 12:39:03 -0600

sapanostic gravatar image

updated 2018-11-05 12:39:31 -0600

I wish to pitch the ground plane. I tried adding "pose 0 0 0 0 0.2 0" to the ground plane model as well as the link model but to no success. Visually as well as collision plane appears to be tilted but the model passes trough the plane and collides with some other plane in the environment.C:\fakepath\Screenshot from 2018-11-05 00-29-20.png

edit retag flag offensive close merge delete

Comments

Mind sharing a minimum SDF file which reproduces the problem?

chapulina gravatar imagechapulina ( 2018-11-05 12:47:30 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-11-07 09:50:52 -0600

azeey gravatar image

I believe this is a bug in Gazebo regarding the way planes are specified. A way around it for now is to set the normal vector as well as the pose. So for your example, the model will be:

<model name='ground_plane'>
  <static>1</static>
  <pose>0 0 0 0 0.2 0</pose>
  <link name='link'>
    <collision name='collision'>
      <geometry>
        <plane>
          <normal>0.199 0 0.98</normal>
          <size>100 100</size>
        </plane>
      </geometry>
    </collision>
    <visual name='visual'>
      <geometry>
        <plane>
          <normal>0.199 0 0.98</normal>
          <size>100 100</size>
        </plane>
      </geometry>
    </visual>
  </link>
</model>
edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-11-05 12:39:03 -0600

Seen: 48 times

Last updated: Nov 07