Home | Tutorials | Wiki | Issues
Ask Your Question
0

Gazebo crashes when trying to launch using static map plugin

asked 2018-11-07 11:44:09 -0600

JROS gravatar image

Hi everyone,

I am fairly new to Gazebo so I am having a hard time figuring this out myself: I was trying to follow the tutorial on the static map plugin (http://gazebosim.org/tutorials?tut=st...) to use satellite imagery from Google Maps in my simulation. I have two machines running a freshly installed Ubuntu 18.04 LTS and Gazebo 3, one at work and one at home. On the machine at work the tutorial worked like a charm. Now I was trying to get the same results on my personal machine, but it won't work. I think there probably is a simple fix to this but I am not sure where to start. I checked the /tmp folder and it looks like all the downloaded files are there so not sure why I am getting this error. See the full output below. Would be great if anyone has a quick fix for this. Thank you!

 $ gazebo --verbose Dropbox/Masterthesis/Simulation/Gazebo-files/Worlds/static_map_plugin2.world 
Gazebo multi-robot simulator, version 9.4.1
Copyright (C) 2012 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

Gazebo multi-robot simulator, version 9.4.1
Copyright (C) 2012 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

[Msg] Waiting for master.
[Msg] Waiting for master.
[Msg] Connected to gazebo master @ http://127.0.0.1:11345
[Msg] Connected to gazebo master @ http://127.0.0.1:11345
[Msg] Publicized address: 10.0.0.88
[Msg] Publicized address: 10.0.0.88
[Wrn] [Event.cc:61] Warning: Deleting a connection right after creation. Make sure to save the ConnectionPtr from a Connect call
[Msg] Downloading map tile: tile_37.386832_-122.065684.png
[Msg] Downloading map tile: tile_37.386832_-122.065255.png
[Msg] Downloading map tile: tile_37.386832_-122.064826.png
[Msg] Downloading map tile: tile_37.386491_-122.065684.png
[Msg] Downloading map tile: tile_37.386491_-122.065255.png
[Msg] Downloading map tile: tile_37.386491_-122.064826.png
[Msg] Downloading map tile: tile_37.38615_-122.065684.png
[Msg] Downloading map tile: tile_37.38615_-122.065255.png
[Msg] Downloading map tile: tile_37.38615_-122.064826.png
terminate called after throwing an instance of 'boost::filesystem::filesystem_error'
  what():  boost::filesystem::rename: No such file or directory: "/tmp/map_satellite_37.386491_-122.065255_100_100", "/home/js/.gazebo/models/map_satellite_37.386491_-122.065255_100_100"
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2018-11-07 16:19:53 -0600

JROS gravatar image

Looks like I fixed it: I created a 'models' folder inside the ~/.gazebo directory and now it worked. Not sure why Gazebo was not able to create that folder itself. Wrong permissions maybe? I'm still interested in the reason, so if anyone has a clue let me know. Thanks!

edit flag offensive delete link more

Comments

Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-11-07 11:44:09 -0600

Seen: 35 times

Last updated: Nov 07