Home | Tutorials | Wiki | Issues
Ask Your Question
0

No shadows or lights in Gazebo

asked 2018-11-20 04:22:01 -0600

RandC gravatar image

Hi there!

I'm having trouble setting up a light in Gazebo. I tried with sunlight, directional light and spot light, and the results of each of those are quite similar, something like this.

image description

I don't know what am I doing wrong, but I tried on another computer with the same settings and they work properly.

I'm using Ubuntu 16.04 LTS with ROS Kinetic

Greetings.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2018-11-20 12:04:04 -0600

I've seen this happening when Gazebo can't find some material resources it needs. Could you try sourcing the setup file before launching Gazebo?

You can find the file as follows:

find /usr -name setup.sh

Then source it like this for example:

. /usr/local/share/gazebo/setup.sh
edit flag offensive delete link more

Comments

I tried to do that, but the sourcing is not clear to me. Should I write "source /usr/share/gazebo/setup.sh"? Because if so, it doesn't work...

RandC gravatar imageRandC ( 2018-11-23 02:50:35 -0600 )edit

Yeah that's what you should do. Run that, and then run Gazebo in the same terminal...

chapulina gravatar imagechapulina ( 2018-11-25 21:34:51 -0600 )edit

Also, if you run Gazebo in verbose mode, do you see any errors? "gazebo --verbose"

chapulina gravatar imagechapulina ( 2018-11-25 21:35:29 -0600 )edit

No error whatsoever. I sourced the path like you said, and then ran Gazebo --verbose. This is the output: Gazebo multi-robot simulator, version 7.14.0 Copyright (C) 2012 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org [Msg] Waiting for master. [Msg] Connected to gazebo master @ http://127.0.0.1:11345 [Msg] Publicized address: 192.168.1.73 [Msg] Connected to gazebo master @ http://127.0.0.1:11345 [Msg] Publicized address: 192.168.1.73

RandC gravatar imageRandC ( 2018-11-26 02:53:58 -0600 )edit

Anyone? I'm still having trouble...

RandC gravatar imageRandC ( 2018-12-10 02:38:15 -0600 )edit
0

answered 2018-12-16 09:01:22 -0600

I've seen this happening with every graphics card except nvidia.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-11-20 04:22:01 -0600

Seen: 112 times

Last updated: Nov 20 '18