Gazebo crashes on VMware linux ubantu 16.04 when subscribe to topic of camera/images

asked 2018-11-28 00:28:34 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I am running node which is publishing images by camera sensor and I am launching this node in gazebo from turtlebot3_gazebo package. cmd is $ roslaunch turtlebot3_gazebo turtlebot3_world.launch

this will launch gazebo with world and turtlebot3 robot. this robot has a LIdar Camera sensor they will publish it's msg on /scan and /camera/rgb/image_raw topic by using sensor/msg.

when I tried to subscribe on this topic /scan it is working. I can view this in rviz and in terminal also but when I tried to subscribe for camera sensor topic to get image information on topic of camera suddenly it gets crashed.

this subscription for camera is done by rviz node by cmd $ roslaunch turtlebot3_gazebo turtlebot3_gazebo_rviz.launch.

[gazebo-2] process has died [pid 26335, exit code 134, cmd /opt/ros/kinetic/lib/gazebo_ros/gzserver -e ode /home/dilip/catkin_ws/src/turtlebot3_simulations/turtlebot3_gazebo/worlds/turtlebot3_world.world __name:=gazebo __log:=/home/dilip/.ros/log/3c81527c-f2d7-11e8-8af9-000c2952350d/gazebo-2.log]. log file: /home/dilip/.ros/log/3c81527c-f2d7-11e8-8af9-000c2952350d/gazebo-2*.log

after that clock of topic /clock get terminated and gazebo process died error 134.

edit retag flag offensive close merge delete