Home | Tutorials | Wiki | Issues
Ask Your Question
0

Gazebo9 hangs on "Preparing Your World..." on macOS Mojave 10.14.1

asked 2018-12-05 17:42:38 -0600

variable gravatar image

updated 2018-12-10 10:59:22 -0600

I seemed to have solved the GUI scaling issue by installing the latest version of qt (5.12.0) but now Gazebo hangs at preparing your world (for hours). It doesn't seem to be downloading any models, /usr/local/share/gazebo-8/models only contains ground_plane and sun. I've tried manually copying all the model folders there but it doesn't help.

This is on both Gazebo8 and Gazebo9

~ gazebo --verbose
Gazebo multi-robot simulator, version 8.6.0
Copyright (C) 2012 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

[Msg] Waiting for master.
Gazebo multi-robot simulator, version 8.6.0
Copyright (C) 2012 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

[Msg] Waiting for master.
[Msg] Connected to gazebo master @ http://XXX.X.X.X:XXXX
[Msg] Connected to gazebo master @ http://XXX.X.X.X:XXXX
[Msg] Publicized address: XX.XX.XX.XX
[Msg] Publicized address: XX.XX.XX.XX
[Wrn] [GuiIface.cc:117] Failed to get QCocoaScreen for NSObject(0x0)
edit retag flag offensive close merge delete

Comments

For me the workaround has been so far to switch between Qt 5.12.0 for RViz and 5.11.2 for Gazebo where the UI is overscaled but kind of usable anyway.

Danylo gravatar imageDanylo ( 2018-12-11 04:46:49 -0600 )edit

I see others are aware of it and working on it here: https://bitbucket.org/osrf/gazebo/issues/2531/gazebo-gui-rendering-is-scaled

variable gravatar imagevariable ( 2018-12-12 11:28:19 -0600 )edit

FYI, I am getting the same problem.

snogar gravatar imagesnogar ( 2018-12-14 15:07:51 -0600 )edit

Did you see my answer that minimizing the window fixes it?

variable gravatar imagevariable ( 2018-12-14 20:44:03 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2018-12-14 15:45:42 -0600

variable gravatar image

Minimizing the window and opening it back up fixes the issue. Sounds like there's a bug fix already submitted.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

3 followers

Stats

Asked: 2018-12-05 17:42:38 -0600

Seen: 74 times

Last updated: 20 hours ago