Color not shown in Gazebo using dae files

asked 2019-01-14 04:02:09 -0600

Eisenhorn gravatar image

I have an issue with Gazebo and color. I am using Blender to attach materials with different colors to different faces of a mesh.

When I export the model as a collada file (.dae) and load it into Gazebo the model has no colors. In rviz all colors show correctly. See screenshot:

image description

I have noticed that the ambiet values in the dae file look like this:

<ambient>
  <color sid="ambient">0 0 0 1</color>
</ambient>

In gazebo the values were set to 1, so I changed all ambient values to

<ambient>
  <color sid="ambient">1 1 1 1</color>
</ambient>

Unfortunately the outcome was the same. I have also added some light sources which didnt help.

My export settings in Blender look like this

image description

The collada file looks like this: C:\fakepath\color_test_3.model

Gazebo version used: Gazebo multi-robot simulator, version 9.6.0

Blender version: Blender 2.79 (sub 0)

ROS version: melodic

OS: Ubuntu 18.04.1 LTS

What could I be doing wrong?

BR

edit retag flag offensive close merge delete

Comments

Exactly the same problem here. Did you find any solution?

rasecg3 gravatar imagerasecg3 ( 2019-05-10 08:30:49 -0600 )edit

I have a similar problem. The object is not even shown at all, when I add a <material> tag in the sdf than it is shown in this color. Did you find any solution yet?

edward gravatar imageedward ( 2019-08-22 07:47:27 -0600 )edit

I have tried it recently again with Belnder 2.79 b. Gazebo is now on 9.11.0. I have used the same export properties and in the material surface settings I choose Diffuse -> chosse color -> intensity was set to 0.8 -> Shader Model Lambert. It seems to work now. Interstingly ambient is 0 0 0 1 ... Could you try with the mentioned versions?

Eisenhorn gravatar imageEisenhorn ( 2019-09-30 03:37:06 -0600 )edit