Home | Tutorials | Wiki | Issues
Ask Your Question
0

LIDAR model publishes upside-down pointcloud

asked 2019-03-26 06:03:20 -0600

RYO gravatar image

updated 2019-03-26 19:57:54 -0600

Hi. I'm now working on to create My Lidar model with Gazebo 7.12.0 tracing this tutorial. Intermediate: Velodyne

and having some trouble with outcoming data.

As you can see in the picture below, I don't know why but every point is published with z coordinates on the opposite sign.

image description

The difference between this tutorial and my model is using vertical parameter for ray. Does anyone have some idea with this?

cheers,

Ryo

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-04-05 09:27:03 -0600

afroRoboticist gravatar image

Maybe you should try creating a different reference link for your lidar sensor.

<link name="laser_optical_link"/>
<joint name="laser_optical_joint" type="fixed">
    <axis xyz="0 1 0"/>
  <parent link="base_link"/>
  <child link="laser_optical_link"/>
  <origin rpy="-${pi/2} 0 -${pi/2}"/>
</joint>

This optical link applies a rotation to your sensor. Now use "laser_optical_link" in your sensor as its frame like below:

 <topicname>/hokuyo/laser/scan</topicname>
        <framename>laser_optical_link</framename> 

Using your new rotated optical link ensures your sensor data is displayed properly in RVIZ.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-03-26 06:03:20 -0600

Seen: 101 times

Last updated: Apr 05