Prevent Model from flexing

asked 2019-04-23 08:17:17 -0600

goldfisch_ralf gravatar image

updated 2019-04-24 00:39:46 -0600

Hi Gazebo Community,

I am working on a Simulation of a Dumper.

image description

Can somebody explain to me why the Model is flexing in y-direction. The articulated steering joint consists out of two joints one in Z direction that is connected to the left part and one in X direction to the front part (pendulum joint). The inertias should be pretty right, but they are heavy (3500 left, 100kg for the steering joint, 10500kg right part). The joint is position controlled in Z direction via ros_control.

What can I do to make the joint only move in z and x direction and rock solid in y?

Attached the urdf joint descriptions of the two joints.

C:\fakepath\joints.model

Edit: Today tried to give the joint link in the middle more mass. It made bending a little bit better but still not solid. Further I also increased the number of iterations but this didn't made any difference.

Complete .urdf File (without the sensors for better readability)

C:\fakepath\dumper.urdf.xacro.model

edit retag flag offensive close merge delete

Comments

Can you please post your URDF file? Need to be able to see that as well. I suspect the problem may be in your URDF file.

afroRoboticist gravatar imageafroRoboticist ( 2019-04-23 12:50:37 -0600 )edit

Hi, I have added the whole file. Have you find any error or improvement?

goldfisch_ralf gravatar imagegoldfisch_ralf ( 2019-04-25 04:17:50 -0600 )edit