Home | Tutorials | Wiki | Issues
Ask Your Question
1

.stl not supported in fuerte-gazebo ? [closed]

asked 2013-04-07 06:16:27 -0500

prasanna.kumar gravatar image

updated 2013-04-07 06:17:11 -0500

Hi,

I am trying to spawn few furniture models in my gazebo world. I am using gazebo in ros-fuerte. I tried them all in ros-electric-gazebo, simple to complicated mesh, .dae or .stl, everything worked but I am have problems spawning them in fuerte-gazebo. And I am getting why they occur.

  1. Some models do not appear at all, be it collada or stl, they do not appear at all.
  2. Some models do not appear as collada but when converted to stl using MeshLab the appear gigantically like this. (Somebody please give me 2 upvotes, I am not able to post images!)
  3. Only one model appears properly as of now like this.

What is the catch ? Why are they erratic ? All the models I have tried so far have worked properly in electric-gazebo.

This is my code in .world file:

<link name='WorkroomChair2_body' gravity='1' self_collide='0' kinematic='0'>
        <origin pose='0.000000 0.000000 0.000000 0.000000 -0.000000 0.000000'/>
        <collision name='WorkroomChair2_top' laser_retro='0.000000'>
          <origin pose='2.475 7.05 0.045 0.000000 -0.000000 0.000000'/>
          <geometry>
            <mesh filename='rtable.stl' size='0.500000 0.650000 1.300000'/>
          </geometry>
          <surface>
            <friction>
              <ode mu='-1.000000' mu2='-1.000000' fdir1='0.000000 0.000000 0.000000' slip1='0.000000' slip2='0.000000'/>
            </friction>
            <bounce restitution_coefficient='0.000000' threshold='100000.000000'/>
            <contact>
              <ode soft_cfm='0.000000' soft_erp='0.200000' kp='1000000000000.000000' kd='1.000000' max_vel='100.000000' min_depth='0.001000'/>
            </contact>
          </surface>
        </collision>
        <visual name='WorkroomChair2_visual' cast_shadows='1' laser_retro='0.000000' transparency='0.000000'>
          <origin pose='2.475 7.05 0.045 0.000000 -0.000000 0.000000'/>
          <geometry>
            <mesh filename='rtable.stl' size='0.500000 0.650000 1.300000'/>
          </geometry>
          <material script='Gazebo/Red'/>
        </visual>
      </link>
    </model>

Thanks!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by nkoenig
close date 2013-07-23 19:04:57.112443

Comments

do you mind sharing the stl or collada file for testing? One thing you can try is to specify the scale of the mesh instead of size because a quick look at the sdf documentation shows that this is the attribute that is expected within the <mesh> sdf element.

iche033 gravatar imageiche033 ( 2013-04-07 21:53:30 -0500 )edit

Yes you are right! My project-mate tried specifying 'scale' instead of mesh and it worked. Thanks. I downloaded all the 3d models from http://www.sweethome3d.com/importModels.jsp and converted them to stl using meshlab.

prasanna.kumar gravatar imageprasanna.kumar ( 2013-04-08 05:31:38 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-04-09 09:56:25 -0500

skhan gravatar image

@kumar, this works well with groovy and seems like the gazebo you are using is the one which is part of ROS. According to recommendations Gazebo with ROS is not fine so use the one at www.gazebosim.org

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-04-07 06:16:27 -0500

Seen: 124 times

Last updated: Apr 07 '13