"gz topic --hz ~/scene" neither "gz topic --echo ~/scene" work

asked 2019-05-17 13:05:38 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi all,

on gzweb sometimes I get a gray screen because it doesn't retrieve the scene from gzserver.

Even if gzserver is running properly, the commands mentioned on the title doesn't respond.

If I try different topics it works fine, so my question is: how to retrieve the scene?

If I run gz topic --info /gazebo/default/scene I see no publishers.

Type: gazebo.msgs.Scene

Publishers:

Subscribers:
    172.18.0.2:44339
    172.18.0.8:36139

If I try gz topic --list | grep scene I can see /gazebo/default/scene, but gz topic --hz "~/scene" never responds and gz topic --echo "~/scene" just finishes with code 0 but without any messages.

If I try gz topic --hz "~/pose/local/info" it works.

If I try gz topic --verbose -e "~/scene" or gz topic --verbose -e "/gazebo/default/scene" I get:

[Msg] Waiting for master.
[Msg] Connected to gazebo master @ http://127.0.0.1:11345
[Msg] Publicized address: 172.18.0.8
[Err] [gz_topic.cc:190] Unable to get message type for topic[~/scene]

gz topic --verbose -e "/gazebo/default/scene"

[Msg] Waiting for master.
[Msg] Connected to gazebo master @ http://127.0.0.1:11345
[Msg] Publicized address: 172.18.0.8
[Err] [gz_topic.cc:190] Unable to get message type for topic[/gazebo/default/scene]

I've tried export GAZEBO_MASTER_URI=http://172.18.0.8:11345 based on the previous output but it doesn't solve the problem

I noticed that if I run gzclient, then gz topic --info /gazebo/default/scene shows a publisher, but still the commands gz topic --verbose -e "~/scene" and gz topic --hz "~/scene" don't work.

Does anybody know how to force the scene to be published?

edit retag flag offensive close merge delete