Home | Tutorials | Wiki | Issues
Ask Your Question
0

Gazebo crash on launch on VMWare on Mac, Ubuntu 16.04, Kinetic

asked 2019-06-22 08:32:43 -0500

Pitosalas gravatar image

I know that this comes up a lot and there are answers but I've not been able to solve this. Let me give my specific case:

  • macbook pro
  • vmware fusion 11
  • vm configured with 8gig, 3d acceleration
  • ubuntu 16.04
  • full kinetic install (includes gazebo)
  • simple simple simulation case crashes

Do you have any clue that could help me troubleshoot?

/catkin_ws/src$ roslaunch turtlebot3_gazebo turtlebot3_empty_world.launch
... logging to /home/pitosalas/.ros/log/56ff08e4-94f1-11e9-866a-000c29ecabe0/roslaunch-ubuntu-3553.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://localhost:32807/

SUMMARY
========

PARAMETERS
 * /robot_description: <?xml version="1....
 * /rosdistro: kinetic
 * /rosversion: 1.12.14
 * /use_sim_time: True

NODES
  /
    gazebo (gazebo_ros/gzserver)
    gazebo_gui (gazebo_ros/gzclient)
    spawn_urdf (gazebo_ros/spawn_model)

auto-starting new master
process[master]: started with pid [3566]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 56ff08e4-94f1-11e9-866a-000c29ecabe0
process[rosout-1]: started with pid [3581]
started core service [/rosout]
process[gazebo-2]: started with pid [3588]
process[gazebo_gui-3]: started with pid [3604]
process[spawn_urdf-4]: started with pid [3612]
[ INFO] [1561209990.986140757]: Finished loading Gazebo ROS API Plugin.
[ INFO] [1561209991.017806263]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...
[ INFO] [1561209991.259239987]: Finished loading Gazebo ROS API Plugin.
[ INFO] [1561209991.262437751]: waitForService: Service [/gazebo/set_physics_properties] has not been advertised, waiting...
[ INFO] [1561209993.643635114, 0.025000000]: waitForService: Service [/gazebo/set_physics_properties] is now available.
[ INFO] [1561209993.761162093, 0.121000000]: waitForService: Service [/gazebo/set_physics_properties] is now available.
[ INFO] [1561209996.612253261, 0.375000000]: Laser Plugin: Using the 'robotNamespace' param: '/'
[ INFO] [1561209996.612348034, 0.375000000]: Starting Laser Plugin (ns = /)
[ INFO] [1561209996.628284054, 0.375000000]: Laser Plugin (ns = /)  <tf_prefix_>, set to ""
[ INFO] [1561209996.667784559, 0.375000000]: Physics dynamic reconfigure ready.
[ INFO] [1561209996.676147365, 0.375000000]: Physics dynamic reconfigure ready.
[ INFO] [1561209996.734885622, 0.375000000]: Starting plugin DiffDrive(ns = //)
[ INFO] [1561209996.735131905, 0.375000000]: DiffDrive(ns = //): <rosDebugLevel> = na
[ INFO] [1561209996.739759221, 0.375000000]: DiffDrive(ns = //): <tf_prefix> = 
[ INFO] [1561209996.770172719, 0.375000000]: DiffDrive(ns = //): Advertise joint_states
[ INFO] [1561209996.783261442, 0.375000000]: DiffDrive(ns = //): Try to subscribe to cmd_vel
[ INFO] [1561209996.815107906, 0.375000000]: DiffDrive(ns = //): Subscribe to cmd_vel
[ INFO] [1561209996.827031593, 0.375000000]: DiffDrive(ns = //): Advertise odom on odom 
[spawn_urdf-4] process has finished cleanly
log file: /home/pitosalas/.ros/log/56ff08e4-94f1-11e9-866a-000c29ecabe0/spawn_urdf-4*.log
VMware: vmw_ioctl_command error Invalid argument.
Aborted (core dumped)
[gazebo_gui-3] process has died [pid 3604, exit code 134, cmd /opt/ros/kinetic/lib/gazebo_ros/gzclient __name:=gazebo_gui __log:=/home/pitosalas/.ros/log/56ff08e4-94f1-11e9-866a-000c29ecabe0/gazebo_gui-3.log].
log file: /home/pitosalas/.ros/log/56ff08e4-94f1-11e9-866a-000c29ecabe0/gazebo_gui-3*.log
^C[gazebo-2] killing on exit
[gazebo-2] escalating to SIGTERM
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2019-06-22 08:45:18 -0500

Pitosalas gravatar image

I just found this and it seems to solve this particular problem for now:

export SVGA_VGPU10=0

Not sure if that is different from turning off 3d acceleration in VMWare.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-06-22 08:32:43 -0500

Seen: 218 times

Last updated: Jun 22